This project is read-only.

500 error after installation

Topics: ASP.NET 2.0
Aug 4, 2012 at 3:37 AM
Edited Aug 4, 2012 at 3:52 AM

I've just installed on my web server, and I'm getting a "500 - Internal Server Error" when I try to access the blogengine app. I'm using IIS 7.5 and ASP.NET 4, and I've changed the application pool to ASP .NET v4.0 Classic. The text of the error says, "There is a problem with the resource you are looking for, and it cannot be displayed."

I downloaded the v2.6 web app (not the source code), and I'm trying to follow the intitial installation steps without doing any special configuration of my own just to get the basics working.

I'm not sure how to turn on logging or debugging in, so I don't know how to extract better information on what's going on.

Any guidance?


Aug 4, 2012 at 6:23 PM

The below is from install steps :

"BlogEngine.NET is developed under an "Integrated Mode" application pool. It is recommended your application pool be in Integrated Mode (as opposed to Classic Mode)."

Also you might turn off custom errors in web.config to get better error message:

<customErrors mode="Off"/>
Aug 4, 2012 at 6:49 PM


I made both changes, and here's the error that I get:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Object reference not set to an instance of an object.

Source Error: 

Line 124:      <providers>
Line 125:        <clear/>
Line 126:        <add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed"/>
Line 127:        <add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
Line 128:        <add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine"/>

Source File: C:\inetpub\wwwroot\BlogEngine\web.config    Line: 126 

Aug 4, 2012 at 10:26 PM

Problem I would never ever be able to recreate this error. It is most likely because conflict in underlying libraries, like Razor version is slightly different or something of this nature. I understand you uploaded it to the server, right? Did you try to install it locally or on the other machine to see if same install works in another environment?

Aug 5, 2012 at 12:39 AM

I'm an optimist and just tried it on my webserver. My other enviroment is set up pretty much the same way, so I don't think I'll see particularly different results. I'll give it a shot, but if any additional suggestions come to mind, please let me know.



Aug 5, 2012 at 6:49 AM

When I run BE app on my development machine using WebMatrix, things seem to work fine. But when I copy the directory to my webserver, I still get the configuration error with the XmlMembershipProvider.


Aug 5, 2012 at 7:03 PM
Edited Aug 5, 2012 at 7:13 PM

So I loaded WebMatrix onto my web server, and if I run BE using WebMatrix as the Administrator and connect to it on localhost, BE works fine. When  access BE from the outside, I get the same configuration error.