This project is read-only.

Web.Config to run v2.6 in subfolder

Aug 28, 2012 at 7:15 PM

I can't get BE v2.6 to run on my server in a subfolder. My host provider says that the BE web.config file needs to be modified so that it will work with the AbleCommerce web.config

Does anybody know what modifications need to be made?


Any help would be greatly appreciated,



Aug 28, 2012 at 9:03 PM

Here is an example of what need to be modified to run in sub-folder. Can differ based on version you running, server configuration, parent application and lots of other factors.

Aug 28, 2012 at 9:27 PM


I am checking with my host provider, but I am quite sure it was set up as a virtual directory when I initiall installed BE v1.6. It worked all that time and I can install v2.0, but v2.6 doesn't seem to work.

Aug 28, 2012 at 10:15 PM

Be 2.6 runs on .net 4.0 which is whole different framework.

1.6 and 2.0 both run on previous .net version, which can be .net 2.0 or 3.5 (because 3.5 is super-set and includes 2.0).

If your parent app is .net 2.0, I doubted you can run BE in sub-folder. May be if they configured as separate virtual directories you can run one under 2.0 app pool and the other under 4.0 application pool. That is, if your host supports it.

Aug 29, 2012 at 12:32 AM

Thank you very much for your help. I already had the .NET upgraded to 4 yesterday.

When I initially installed BE 1.6, I had to modify my AbleCommerce web.config with <location path="." inheritInChildApplications="false">

It ran fine until I tried to upgrade. I had been working on this since last week and figured out I needed .NET 4. My Host provider was going to do it over the weekend, but they said they ran into problems with it and so completed it on Monday night. I think that maybe they redid my web.config (for AbleCommerce) in the process because those <location path="." inheritInChildApplications="false"> were no longer there. I discovered that this afternoon, after I held in my frustration, and thought to check EVERYTHING from the start.

Anyway, it is working now and I thought I should post this to help others with the same problem. Here is what I did. Keep in mind it is specific to AbleCommerce being the root application.

In the web.config file in the root directory (the web.config file for Able -- not the BE web.config file), I would wrap the existing <system.web> and <system.webServer> sections in the following location tags.

<location path="." inheritInChildApplications="false">
............ existing content .............

<location path="." inheritInChildApplications="false">
............ existing content .............

(you may or may not have the <system.webServer> section)

This will prevent settings from propagating down to sub-applications like BE.


I hope this helps somebody.