New Installation 1.4.5 - 404 Error

Topics: ASP.NET 2.0
Nov 11, 2008 at 7:45 PM
I have followed the instructions for installing BlogEngine and I am getting a 404 Error.

I am attempting to run BlogEngine on Windows 2003 Server Service Pack2.

I have the Website set to ASP 2.0
I have all the permission set of IIS_WPG, IUSR, IWAM, ASP.NEY, Network, Network Service and still I am getting the 404 error.

This is VERY frustrating. I am fairly proficient with Windows Servers and ASP.NET ... so Why is it SO difficult to install these ASP.NET projects and get them running?

I can hit the index.htm file that is on the website, but not the default.aspx file.

http://be.shannoncase.com/index.htm

http://be.shannoncase.com/default.aspx

Any help would be GREATLY appreciated. I am not really sure where to look next.

Sincerely,
Shan


Nov 11, 2008 at 8:22 PM
Update: I am able to install BlogEngine without issue on my local machine. The install went exactly like the instructional video for v1.3 does.

Not sure why it doesn't work on my Win2k3 Server. :(

Shan
Nov 11, 2008 at 11:25 PM
If you feel comfortable giving access to your box to a complete stranger... I'd be willing to look it over for you.

I've been a BE user since 1.0... have wrote a couple of extensions and such, so I'm not a complete stranger to the BE community.

Post contact information here and I'll touch base with you asap.  I have all the major IM clients.
Nov 11, 2008 at 11:28 PM
I would be willing to bet that you do not have asp.net set as an allowed extension in IIS. Maybe try re-registering .Net in IIS.
Nov 11, 2008 at 11:40 PM
I don't think that would be it, as that generally shows up with an error like this:
http://www.ocdprogrammer.com/post/2008/08/10/Failed-to-access-IIS-metabase.aspx

However it never hurts, I have the command line you need on that blog post.


Nov 11, 2008 at 11:57 PM
I agree, check that .NET 2.0 extensions are allowed and that your default document is Default.aspx.
Nov 12, 2008 at 12:01 AM
It is not a default doc issue because the direct link to the aspx fails (though that could be an issue on top of all other issues).

I am wondering if its a worker process issue.  As a worker process can only work on one framework at a time, and if the site is setup to use a worker process that uses .net 1.1... he'd be hosed.
Nov 12, 2008 at 12:38 AM
Yeah, probably not the default document.  Try re-running the command C:\Windows\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -i to re-register .NET 2.0 on the website, then make sure you have enabled ASP.NET v2.0 on the web services extensions of the IIS Management Console...  
Nov 12, 2008 at 12:51 PM
I want to thank everyone for their input. I had to re-run the aspnet_regiis.exe for .NET 2.0.

The site started to work after that. I had permissions issues after that.

I had ASP.NET set with write permissions, but had to add IIS_WPG as well before everything would work.

Thanks again!

Shan