Problem linking

Topics: ASP.NET 2.0, Business Logic Layer, Controls
Oct 19, 2012 at 6:19 PM

Hello all,

 I have a blog running blogengine 2.6 that is working fine. However I cannot 'share' posts on Facebook. Either with share button in the 'Social Share' extension or by copy/pasting the post url into Facebook directly.

The post is published and is viewable even with I am not logged in.

You can visit the url without problem

But when attempting to share the url, I get a "Page Not Found" error on Facebook. Someone else told me they tried to share a post and got an error that it the url was redirected as

 How does blogengine "create" the pages for posts dynamically? Could there be a problem with the way it is doing it?

Any ideas?

Oct 19, 2012 at 8:28 PM

Hm, I remember someone else bringing this issue, I'll try to check this out this weekend. Seems like an odd behavior, could be something in URL rewrite causing it.

Oct 20, 2012 at 6:05 PM

Ok, I added page on facebook and shared links (copy/pasted to timeline) from blog running 2.6 and then another blog running current build from latest source. Both links work fine, so I'm guessing there something specific to your site that brakes it. What page you trying to share? I can try it and may be it'll give me some clues.

Oct 20, 2012 at 7:48 PM

Thank you. I did some more playing around with it and determined that your right, it's not a problem with BE. I'm hosting with Godaddy and it is including the directory name in the path to the post. i.e.

The page is still reachable like this, but Facebook wont find it unless you remove the directory name from the url.

How can I change the url rewrite rules in BE to remove the directory name?