Posts and comments not visible in admin view

Jan 7, 2013 at 4:08 AM

I upgraded to 2.7 a while ago, everything seemed OK. I do not post often enough to know when it happened, but now when I log in to deal with comments, if any, the comments do not show up at all, neither pending nor approved. It shows the number of comments, but none of the text nor label.

The same is true of the Posts. They show up fine on the main page but not on the admin page.

Kal

 

 

Coordinator
Jan 7, 2013 at 5:34 PM

You probably have JavaScript errors - all these lists loaded with Ajax calls. If you have optimization on (admin/settings/advanced) try to turn it off. Some other settings in advanced, like HTTP compression, can also cause this kind of issues.

Jan 8, 2013 at 1:20 AM

Settings | Advanced gives on clicking Save Settings
SCRIPT438: Object doesn't support property or method 'validate'
advanced.aspx, line 68 character 13
            $(frm).validate({
                onsubmit: false
            });
   
Opening Post or Comments gives
SCRIPT438: Object doesn't support property or method 'cookie'
js.axd?path=%2fadmin%2fadmin.js, line 125 character 5
SCRIPT438: Object doesn't support property or method 'cookie'
js.axd?path=%2fadmin%2fadmin.js, line 125 character 5
   $.cookie('CommentPagerCurrentPage', pg, { expires: 7 });

I downloaded jquery 1.8.3 and tried that, but no improvement.

Suggestions?

i changed the httpcompression and compresswebresource in the database. Are there any othere optimization settings?

Kal

Coordinator
Jan 8, 2013 at 3:09 PM

Check JS scripts with FireBug, you either missing a script or have conflicting duplicates.

All scripts in /scripts/header folder added to page header and from /scripts folder added at the end of the page automatically.

Jan 12, 2013 at 4:35 AM

It was a URL rewrite rule. When enabled, both posts and comments are blank. When disabled they work as expected.

<rule name="LowerCaseRule1" stopProcessing="true">
     <match url="[A-Z]" ignoreCase="false" />
     <action type="Redirect" url="{ToLower:{URL}}" />
</rule>

I did a fresh install which did not solve the problem but when I did a web config without the rewrite rules it worked . After that it was just necessary to identify the offending rule.

Thanks for your help.

Kal