This project is read-only.

Can't login. BE2.0, fresh install

Feb 26, 2013 at 3:25 PM
Edited Feb 26, 2013 at 3:29 PM
Hi BE gurus!

I'm trying to install BE2.0 on a MS ASP.NET/.NET Framework 3.5 hosting. A fresh clean install. All works fine, I can see the welcome page, able to come to archive and contact pages and so on. But I can't log in here

When I put the default Username and password and press login it returns the page full of strange characters like these ones:
T�,� ��1��z}����L��шc���k�1X��䉐w��X)��� �%��U��|�s^0h- �(��f9���ߖ"M5+ .�hxHM\bX��<�~�!�ܠ�w�)2�l�-�õ ̕a�+�T�;PK4���9. ��@�z�v-˔s��a<��sk�d�2AU��ȵ,��pOgɖz���EIPӝj��� ln%�6��غ�P1�{�^��������

The firebugs writes this:

[16:17:43.223] POST [HTTP/1.1 302 Found 235ms]
[16:17:43.457] GET [HTTP/1.1 500 Internal Server Error 250ms]
[16:17:43.717] Use of Mutation Events is deprecated. Use MutationObserver instead. @ chrome://firebug/content/chrome/tabContext.js:589
[16:17:43.848] The Web Console logging API (console.log,, console.warn, console.error) has been disabled by a script on this page.

Please could you help?

Feb 26, 2013 at 4:47 PM
What you can do is to disable compression to display real server-side error. Open /app_data/settings.xml file and set these two values to false:

Feb 26, 2013 at 6:04 PM
rtur thank you very much for answering!
These 2 values were set as false there, there is nothing to change. But I've noticed another thing. I feel I should tell the full story...

I have another blog on BE2.0 running in the other folder on that site and it has been running fine from 2010. Recently I put there an affiliate code from a company in the widget zone. The code was a searchbox and I put it via Textbox widget. Next day I got HTTP Error 500.19 and the hoster said it was due to their feature "Code Access Security" (CAS) imposed on ASP.NET (a shared hosting). The error pointed to the

<section name="scriptResourceHandler"
System.Web.Extensions, Version=, Culture=neutral,
PublicKeyToken=31BF3856AD364E35" requirePermission="false"

within the web.config file of the blog. I suspected that this widget has caused the error and deleted it (its xml file in the ...datastore/widgets folder) via ftp (I can send its code to you privately).

The blog was restored and then I tried to login but couldn't with the similar error occurred. I thought that some code from the widget is still remaining somewhere and decided to set up a clean install, make it running and then transfer the useful content to it from my corrupted blog. But as you know now I got the same error with the fresh install too. The another thing I've noticed while following your advice is that the settings.xml of the fresh install is the same as of my broken blog. How can it be possible??? The folders are different and created within the root directory, they run as 2 applications assigned accordingly. And what to do now please?

Feb 26, 2013 at 8:34 PM
So you pushed clean install in that site but somehow settings.xml ended up different and looks like it came from old corrupted site? Seems like an error, either you pushed wrong file or FTP chocked on it. I'd blame FTP :) Try to delete all and then do another clean install making sure you pushing good files and there is no errors thrown by FTP client. And maybe check settings.xml before you run app to make sure it is not overwritten somehow after install.
Feb 28, 2013 at 3:20 AM
Edited Feb 28, 2013 at 6:35 AM
Yeah, that mysticism has me in the origin - when I get files from the site with the FTP client it asks me if I wish to overwrite my local copy and I answered NO. But thus it opens the local copy which was a copy of the blog )))))

So Fresh Clean Install-2. I uploaded the BE2.0 zip to the site in a new app directory, unzipped it there, made settings checked, and started the app. The login problem still remains but has altered.

= The first load of the homepage has an error - it loads itself within the blogroll widget (I can't find how to upload images here) so I here the code is:
    <div class="widget blogroll"
<div class="content">

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
    <html xmlns="" xml:lang="en" lang="en">
    <head profile="">
    <link type="text/css" href="/BE2/themes/Standard/css.axd?name=/BE2/Styles/Global2.0.0.36.css" rel="stylesheet" />
    <link rel="stylesheet" href="/BE2/themes/Standard/css.axd?name=style2.0.0.36.css" type="text/css" /><link rel="shortcut 
and so on with the error message publishing inside this homepage-2:
    This one's down to me! Please accept my apologies for this - I'll see to it
    that the developer responsible for this happening is given 20 lashes 
    (but only after he or she has fixed this problem).
But the home page doesn't publish any error messages. The Firebugs is full of errors starting with:
    [02:36:31.059] TypeError: function Ka does not always return a value @
    [02:36:31.059] SyntaxError: test for equality (==) mistyped as assignment (=)? @
I don't know if it took place earlier as it is hard to notice - it is at the right bottom of the screen and the letters of the blog name are in white color. I revealed it via the page code when noticed the <!DOCTYPE line in red and in the middle of the page. (upd: I revised the code and it loads error.aspx page there)

= When I reload the home page the widget blogroll works as it should be (the homepage-2 has gone from within it) but the Firebugs is the same full.
= Now login. It doesn't work and returns now this:
    Server Error in '/BE2' Application.
    Runtime Error
    Description: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated.
meanwhile Firebugs writes this:
    [02:56:10.723] POST [HTTP/1.1 302 Found 469ms]
    [02:56:11.210] GET [HTTP/1.1 500 Internal Server Error 1219ms]
    [02:56:12.388] Error in parsing value for 'cursor'.  Declaration dropped. @
I'm in trouble... So many wrong things... Does there indeed exist anyone who sees the way to the sun? ))) Rtur please what should I turn on/off?

Mar 4, 2013 at 11:21 PM
Edited Mar 4, 2013 at 11:21 PM
Hi rtur,

Please do you have any idea on how to fix the issue? Maybe it is a hoster-side related? They say all is fine so I have to be specific to point them at the cause...

Mar 5, 2013 at 4:06 AM
Not sure what your steps are and why you getting all those errors, but if this is initial install you could:
  1. Get fresh download to local PC and set it up on local IIS to make sure it works.
  2. Delete all from server directory and upload site tested in step #1.
If it still doesn't work or you can't do it this way, please describe steps you doing and where you run into first error.
I know if all seems obvious when you run it yourself, but I've been more then once in situation trying to troubleshoot error and finding that it actually running modified code in sub-folder under parent app :)