This project is read-only.

Video not showing

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Mar 17, 2013 at 6:29 PM
Hello Experts,

Can anyone please explain to me why video is not showing?

I click on Insert Video and when I look into Media folder, the video is inserted but it doesn't display.

Any ideas why it doesn't display and how to make it display would be greatly appreciated.
Mar 18, 2013 at 4:24 PM
No response????
Mar 18, 2013 at 5:32 PM
In the /setup/testfiles there is "sample.flv" file - this is a video file used during testing to make sure inserted video works fine. Try this file to verify that it is not an issue with your video. If it does not work either, check page source for "sample.flv" and see if it has video tag generated, should look like:
<video class="mep" controls="controls" src="/be/media/sample.flv"></video>
If tag it there and looks ok, try to navigate to this file manually, it should let you download video - if not you may not have read permission on media folder.
Mar 18, 2013 at 10:31 PM
Thanks rtur,

For some reason, I have struggled all day to connect to the internet.

I tried pretty much everything you told me and stil the video is not showing.

I even gave everyone permission to the media folder.

I did, however, get a couple of errors:

jquery is undefined and object expected. These errors point to:

Line: 420
Error: Object expected

_<script type="__text/javascript">
jQuery(document).ready(function($) {
$('audio.mep, video.mep').mediaelementplayer({defaultVideoWidth:480, defaultVideoHeight:360});

Line: 13
Error: 'jQuery' is undefined___
Mar 19, 2013 at 2:56 PM
Yes script errors can break client-side code like one used by media player. Most ofter reason for jQuery not defined is because there is more than one jQuery loaded on the page or errors in optimization cause bundle of scripts fail to load. So make sure you not loading conflicting jQueries and turn optimization off in admin->settings->advanced to let every script load separately.
Mar 20, 2013 at 5:59 PM
Thank you rtur.

Turning off optimization in admin fixed it.

Hopefully, there are no side effects to turning this off.

Thanks again