Flash Load Problem

Topics: ASP.NET 2.0, Themes
Jan 9, 2009 at 12:19 AM
Hello all,

For my website blog on Citrus SEO (http://www.citrus-seo.com/blog/) I have flash bubbles floating behind the can above the blog and everything is fine on the main blog page however once you drill down to a post permalink (for example, the latest post) the bubbles are missing and the icon for "get adobe flash player" is there. I can't figure out why its doing this or how to fix it.

Can anyone please help me?!

Thanks so much!

Coordinator
Jan 9, 2009 at 3:38 AM
There are two JavaScript files not being loaded on these other pages -- global.js and swfobject.js.  The two <script> tags for these files are:

<script type="text/javascript" src="_js/global.js"></script>
<script type="text/javascript" src="_js/swfobject.js"></script>

Most likely these two lines are in the site.master file in your theme folder.  You should be able to modify those 2 lines above to the following so the JavaScript files will be loaded on all your blog pages (and so you'll get your bubbles back :-)

<script type="text/javascript" src="/blog/_js/global.js"></script>
<script type="text/javascript" src="/blog/_js/swfobject.js"></script>
Jan 9, 2009 at 6:17 PM

I had the same problem, solved it in the following way  :

<head runat="server">
<script src="<%# ResolveUrl("~/themes/MyThemeName/swfobject.js") %>" type="text/javascript">
</script>
</head>

<body id="theBody" runat="server">

<div id="flash">
<div id="flash1">
<a href="<%=Utils.RelativeWebRoot %>" rel="home"><%=Resources.labels.home %></a>
</div>

<script type="text/javascript"> 
var fo1 = new FlashObject( "<%=Utils.RelativeWebRoot %>themes/MyThemeName/movie1.swf", "movie1", "125", "211", "6", "#ffffff");
fo1.addParam("base", "<%=Utils.RelativeWebRoot %>themes/MyThemeName"); 
fo1.write("flash1");  
</script>  
</div>

</body>


Jan 9, 2009 at 6:58 PM
Thanks BenAmada!!! That worked!!! Yay! You totally made my day haha. Thanks for your help! :-D
Jan 13, 2009 at 3:25 PM
I'm trying to make flash work in v1.4.5 using the Leaves theme and I can't find these two javascript files anywhere.  Where can I find swfobject.js and global.js?