BlogEngine.NET not picking up manually created posts

Topics: ASP.NET 2.0, Business Logic Layer
Apr 10, 2013 at 12:29 AM
I'm porting a blog from WordPress to BlogEngine.NET. I've written a small WinForm app in C# which reads in all the web pages (i.e., posts) from the WordPress site and outputs an XML file for each post. Then, I FTP'd them up to the BlogEngine.NET site and put them under App_Data/posts.

At that point, I navigated to the "Posts" page of the blog where I expected to see a list of all the posts. Unfortunately, only the single sample post included with BlogEngine.NET shows up.

Why aren't my posts showing up?
Apr 10, 2013 at 1:50 AM
Have you tried restarting the application pool on IIS? I tried a similar thing to what you are doing by duplicating the sample post file and changing the guid just enough so the format matched but the names were different. Both posts are showing up in my local install. I think you many be experiencing a caching issue.
Apr 10, 2013 at 1:47 PM
Hi Birdus,

I saw your post also on stackoverflow and I replied saying basically the same what Leemicw is saying.

You have to restart your app_pool.
Apr 10, 2013 at 7:52 PM
Great, guys! That worked! Thanks!
Apr 10, 2013 at 8:12 PM
Hi Birdus,

No problem.

That is what we are here for to help out when we can!