Resources not showing up when working locally

Topics: ASP.NET 2.0, Business Logic Layer
Jan 16, 2009 at 12:30 AM
I have the following situation:
I have downloaded the 1.4.13 build. I am working in parallel with the Core and the Web project.
When I build the website everything seems ok.

I can upload resources to posts. After uploading I have them correctly displayed in the post.
But on the list of all posts the resources(pictures fore example) are missing.

I have investigated why and it turns out that the request that gets sent is
http://localhost:49218/image.axd?picture=2009%2f1%2fcestitka.jpg
instead of
http://localhost:49218/blogengine/image.axd?picture=2009%2f1%2fcestitka.jpg

How can I take care of this without affecting anything other? I know that I can just change to Server.MapPath on every handler but that
is a very stupid solution :)

Coordinator
Jan 16, 2009 at 2:28 AM
Edited Jan 16, 2009 at 2:29 AM
It sounds like you have run into this issue.
Jan 16, 2009 at 2:52 AM
hehe, thank you BlogEngine guru :D
Jan 16, 2009 at 3:32 AM
Also, because of the update of the tiny_mce to tiny_mce3 the Smilies extension is not working properly.
In App_Code/Extensions/Smilies.cs the line:

private const string LINK = "<img src=\"{0}editors/tiny_mce/plugins/emotions/images/smiley-{1}.gif\" class=\"flag\" alt=\"{2}\" />";

should be changed into:

private const string LINK = "<img src=\"{0}editors/tiny_mce3/plugins/emotions/img/smiley-{1}.gif\" class=\"flag\" alt=\"{2}\" />";

Coordinator
Jan 16, 2009 at 3:55 AM
Nice find Mario :-)  I created a work issue for this so it's more official and will hopefully get fixed in the near future.

Link in Smilies extension needs update w/new version of tinyMce
http://www.codeplex.com/blogengine/WorkItem/View.aspx?WorkItemId=8933
Jan 16, 2009 at 3:56 AM
woooohoo :)