blogengine.net iis publish blog - error 330 on post

May 20, 2013 at 9:50 AM
Hi to all,
I describe my problem.

I created a blog with BlogEngine.net and until now had worked out well.
After the last Publish, some blog posts have started to give me this error when I tried to open them:

[This webpage is not available
The webpage at http://blog.roundfit.com/post/2013/01/29/3-reasons-to-stop-thinking-to-eat-or-not-to-eat.aspx might be temporarily down or it may have moved permanently to a new web address.
Error 330 (net :: ERR_CONTENT_DECODING_FAILED): Unknown error.]

As suggested on a website (I think here), I deleted the line from the Web.config file:
[<add Name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" />]

and at that point the error is changed to this:

[Error Details:
Url: http://blog.roundfit.com/post.aspx?id=ae58c23e-10ad-45d0-aa71-77bb93abce23

Raw Url: / post/2013/01/29/3-reasons-to-stop-thinking-to-eat-or-not-to-eat.aspx

Message: Exception of type 'System.Web.HttpUnhandledException' was thrown.

Source: System.Web

StackTrace: at System.Web.UI.Page.HandleError (Exception e)

at System.Web.UI.Page.ProcessRequestMain (Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest (Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest ()

at System.Web.UI.Page.ProcessRequest (HttpContext context)

at ASP.post_aspx.ProcessRequest (HttpContext context) in c: \ Windows \ Microsoft.NET \ Framework64 \ v4.0.30319 \ Temporary ASP.NET Files \ root \ e22c2559 \ 92c7e946 \ App_Web_4qyul002.8.cs: line 0

at

at System.Web.HttpApplication.ExecuteStep (IExecutionStep step, Boolean & completedSynchronously)

TargetSite: Boolean HandleError (System.Exception)

Message: Expression must evaluate to a node-set.

Source: System.Xml

StackTrace: at MS.Internal.Xml.XPath.XPathParser.ParseNodeTest (AstNode qyInput, AxisType AXISTYPE, XPathNodeType nodeType)

at MS.Internal.Xml.XPath.XPathParser.ParseStep (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseRelativeLocationPath (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseRelativeLocationPath (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseLocationPath (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParsePathExpr (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseUnionExpr (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseMultiplicativeExpr (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseRelationalExpr (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseEqualityExpr (AstNode qyInput)

at MS.Internal.Xml.XPath.XPathParser.ParseOrExpr (AstNode qyInput)

at MS.Internal.Xml.XPath.QueryBuilder.Build (String query, Boolean allowVar, Boolean allowKey)

at System.Xml.XPath.XPathExpression.Compile (String xpath, IXmlNamespaceResolver nsResolver)

at System.Xml.XPath.XPathNavigator.Select (String xpath)

at System.Xml.XmlNode.SelectNodes (String xpath)

at post.OnInit (EventArgs e)

at System.Web.UI.Control.InitRecursive (Control NamingContainer)

at System.Web.UI.Page.ProcessRequestMain (Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

TargetSite: MS.Internal.Xml.XPath.AstNode ParseNodeTest (MS.Internal.Xml.XPath.AstNode, AxisType, System.Xml.XPath.XPathNodeType)]



At this point I honestly do not know what to do and if anything have any ideas to help me I would be grateful.

Latest information, the blog has been developed on Visual Studio 2012, and is located on a remote server on IIS 7.

This problem gave it to me after I did the last Publish, the blog, Visual Studio, and then I brought the whole package to the folder "wwwroot" IIS on the server.

Thanks in advance.