This project is read-only.

[more] linkk not working

Topics: ASP.NET 2.0, Controls
Jun 24, 2013 at 5:42 PM
Edited Jun 24, 2013 at 5:57 PM

I have just installed the latest BE, and set up a test blog. I was trying out the [more] link, but it's not working correctly.

If I start a new blog entry, and type a paragraph, then type [more] on a new line, then type more stuff below it, when I look at the blog home page, it looks correct, but if I hover my mouse over the more link, the URL is http://mydomain/post/#continue instead of pointing to the blog entry page.

If I click the link, I get an HTTP 404 error.

I tried using the code shown on this post, but it didn't help, the link was the same.

How do I fix this please? I would like the link to take you to the individual blog entry page.

Jun 24, 2013 at 7:33 PM
Edited Jun 24, 2013 at 7:33 PM
Try something simple to make sure you don't have anything in the post that breaks "more" function. For example, add post with just:

Some text [more] and some more text.

Although I'm not sure what would break it, using it with 2.8 on several sites and never seems to have an issue.
The link should be http://yourdomain/post/post-slug#continue
Jun 24, 2013 at 8:24 PM

I forgot to mention that I did that. I added a new line on either side of the [more], but that didn't make any difference. I just tried your test exactly, and the same thing happened.

This is a brand new installation, right out of the box. Any idea why my links aren't working?