Error at admin login

Topics: Controls
Sep 18, 2013 at 5:36 PM
Edited Sep 18, 2013 at 5:37 PM
For no apparent reason I can't log in to admin on my blog http://korpgluggen.se (Blogengine.NET 2.7). It's worked flawlessly until this friday when the site went down for the whole weekend. Back up again all I get when logging in is "Ooops! An unexpected error has occurred." and no forwarding to the admin dashboard.

Thankful for all help!
Sep 19, 2013 at 7:47 PM
I'm not a BE expert but it could be a lot of things depending. Are you able to access your event logs for when this happens? That'll shed a lot more light on what might be causing it. Another thing might be how you're storing data; depending on why the site went down (e.g. sudden power loss) the files storing your admin/login data might have become corrupt if you're using flat file/xml storage. Lastly, does the blog itself, the non-admin parts, still work?
Sep 19, 2013 at 8:52 PM
Thank you for the answere! The site itself is up and going, only that I'm "locked out" from the admin parts including the log. I've been able to reset the log in password, but it doesn't help me getting in, so I don't think it's about corrupt XML-data.
Sep 19, 2013 at 11:04 PM
What I meant by the event logs was the Windows Event Viewer > Application Events. I'm not sure if BE errors show up here (the BE log might hijack those errors so they never show up but it doesn't hurt to check).
Sep 26, 2013 at 2:53 PM
I'm still not sure what went wrong, but I managed to resolve the admin-problem by re-uploading all my blogengine files, overwriting the (probably corrrupt) remote files. Thanks a lot for your helpful input!
Sep 26, 2013 at 4:26 PM
Check the login password that you had in XML or DB provider. Also, are you able to access the login page directly vai URL.
e.g http://korpgluggen.se/Account/login.aspx