Setup problem with current version

Feb 11, 2009 at 2:42 AM
My website will be hosted on an host site.  In preparation, I added a virtual sub-dir named blog.  The root directory contains only the placeholder default.aspx for my webiste when I install it.

I followed the instructions in your video on installation and installed the blogengine files in the sub-directory.  When I use the url "blog.website.com", I get the blogengine home page.  One of the images on the menu, "feeds", is not shown and when I press login, I get the following:

Server Error in '/blog' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /blog/blog/login.aspx


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


Any help you can give me will be greatly appreciated.  Thanks.
Coordinator
Feb 11, 2009 at 4:34 AM
Is your blog hosted at GoDaddy?  If so, there's been a number of discussions about subdomain issues with GoDaddy.  Here's one, but you can search the Discussions here for "godaddy" to find more.

If you're not at GoDaddy, what value do you have for BlogEngine.VirtualPath in your web.config file?  Is it "~/" or "~/blog/"?  Is your blog accessible via www.website.com/blog (not using the subdomain)?  If so, do you still get that error when clicking on "feeds" while accessing your blog via www.website.com/blog?
Feb 11, 2009 at 5:54 PM
No, not at GoDaddy but at WebHostForASP.net.  I read all of those discussions before posting my question.  BlogEngine.VirtualPath is "~/" (this is the first thing I looked at).  I can not access it at www.website.com/blog , it takes me to the parked main page.
Coordinator
Feb 11, 2009 at 8:09 PM
It's possible your web host uses the same type of url rewriting technology as GoDaddy (but I'm not sure).  Is the blog subdirectory configured as a 'web application' or 'application starting point'?  You said virtual sub-dir, and maybe that's the same thing.

One thing you could test, is adding the bolded code below in your default.aspx page.  Then pull up your blog's home page and look for the 2 new lines of text it outputs.  What text do you get?

<asp:Content ID="Content1" ContentPlaceHolderID="cphBody" Runat="Server">
  VirtualPathUtility.ToAbsolute("~/"): <%=VirtualPathUtility.ToAbsolute("~/") %>
  <br />
  VirtualPathUtility.ToAbsolute("/"): <%=VirtualPathUtility.ToAbsolute("/") %>
  <br />

 
  ... existing stuff ...
Feb 11, 2009 at 9:20 PM

I added the code you suggested and these are the results:

VirtualPathUtility.ToAbsolute("~/"): /blog/
VirtualPathUtility.ToAbsolute("/"): /

I then tried to change the Virtual path to “/” and stopped and restarted the site. I opened up the blog, hovered over the link for login which showed the correct url “blog.mywebsite.com/blog/login.aspx”, but when I tried to login I get the same error about \blog\blog\....

Thanks again.

John Baird

MVP_Horizontal_FullColor

Coordinator
Feb 11, 2009 at 9:44 PM
Just wanted to clarify, you get the \blog\blog error when you are on the homepage and click the "Login" hyperlink?  Or can you get to the login page successfully, but when you click the "Login" button, that's when the error occurs?

If you can get to the login page, before you click the "Login" button, if you do a View Source, what is the "action" attribute of the <form> tag.  I'd expect it to be ...

<form action="/blog/login.aspx">

I was also just curious why you're using the 'blog' subdomain if you also have 'blog' as a subfolder in the url.  In other words, I'd think you would want it to either be:

blog.website.com/login.aspx
-- or --
www.website.com/blog/login.aspx

But it sounds like you have it combined right now ...
blog.website.com/blog/login.aspx

Just wondering since maybe setting it up differently could help ... www.website.com/blog/login.aspx is the most straight forward, "textbook example" :)
Feb 12, 2009 at 6:26 PM

Ben,

Thanks for your help.  What I finally did was create a real sub-domain and copied the files into there.  Works like a charm.

John

From: BenAmada [mailto:notifications@codeplex.com]
Sent: Wednesday, February 11, 2009 4:45 PM
To: jbaird@quayinc.com
Subject: Re: Setup problem with current version [blogengine:46795]

From: BenAmada

Just wanted to clarify, you get the \blog\blog error when you are on the homepage and click the "Login" hyperlink? Or can you get to the login page successfully, but when you click the "Login" button, that's when the error occurs?

If you can get to the login page, before you click the "Login" button, if you do a View Source, what is the "action" attribute of the <form> tag. I'd expect it to be ...

<form action="/blog/login.aspx">

I was also just curious why you're using the 'blog' subdomain if you also have 'blog' as a subfolder in the url. In other words, I'd think you would want it to either be:

blog.website.com/login.aspx
-- or --
www.website.com/blog/login.aspx

But it sounds like you have it combined right now ...
blog.website.com/blog/login.aspx

Just wondering since maybe setting it up differently could help ... www.website.com/blog/login.aspx is the most straight forward, "textbook example" :)

Read the full discussion online.

To add a post to this discussion, reply to this email (blogengine@discussions.codeplex.com)

To start a new discussion for this project, email blogengine@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Apr 3, 2009 at 7:29 AM
Hi all,

I have an interesting stuff I would like to share regarding the BlogEngine.NET application. I have my blog hosted at ASPHostCentral.com (http://www.asphostcentral.com) and they are a great host for my BlogEngine.NET application.

Firstly, I tried to install the application on my subfolder, something like http://www.myDomain.com/blog. The installation works fine and I can load my BlogEngine application. However, the problem starts to happen when I tried to edit the "Author" section, which is normally located at the top right hand corner of the site. It always throws me with an error, saying that I do not have enough permission to do it, bla bla bla. I checked all the permissions and I can ensure that the WRITE permissions are all set. I did read about BenAmanda post about altering some settings on the BlogEngine, but I just decided not to pursue further.

I then uninstalled the application and then install it on a SUBDOMAIN instead. It works fine and I can edit the Author and other sections without any problem. Probably, this is a minor bug that the BlogEngine team needs to fix. After all, to prevent any headache, I strongly suggest you guys to install it on a subdomain directly.

Hope this helps.


Kind Regards,

C. Tevez