This project is read-only.

Posting Comments Captcha Error

Topics: Controls
Nov 18, 2013 at 10:08 AM
Hi there,

I don't seem to be able to post on one our blog anymore.
Please see the screenshot attached.

I'm not sure what causes this issue but I believe it has to do with the change of url of Google's recaptcha plugin.

Any help on how to amend that would be appreciated. Thanks.

Nov 18, 2013 at 6:11 PM
Try to disable TypePadFilter extension if it is enabled, it seems to have API issue lately.
If it is disabled, do the same with Recaptcha to see if it fixes problem - try to confirm that is is indeed recaptcha problem.
Nov 19, 2013 at 9:03 AM
Hi rtur

thanks for your reply! I disabled TypePadFilter and both Recaptcha and simpleCaptcha. I was then able to post comments.
However when I enabled Recaptcha (leaving TypePadFilter and SimpleCaptcha disabled), I got the 'value cannot be null. Name of parameter Challenge'.
I also tried to enable SimpleCaptcha and leaving the other two controls disabled. this worked fine.

When Recaptcha is enabled, I've inspected the page in Chrome and noticed the following error:

Failed to load resource: the server responded with a status of 404 (Not Found)

The url seems obsolete. Would point to instead help?

Please keep us posted :)

Nov 19, 2013 at 9:21 AM
Hi rtur

I've just updated the url in the RecaptchaControl.cs file in my code and, although this adds a recaptcha box on the page, I can add comments no problem.

Nov 19, 2013 at 2:52 PM
Ok, that makes sense, We probably should make this a setting for Recaptcha and let it be updated from UI for the next version.
Nov 19, 2013 at 3:13 PM
Cool, thanks.
Nov 23, 2013 at 3:52 PM
Edited Nov 23, 2013 at 3:52 PM
A few of our BE sites are also experiencing this problem. Disabling ReCAPTCHA allows you to post again, but it also opens the floodgates for SPAM. I updated the URL in the code, but ReCAPTCHA does not display or function. Has anyone else been able to get this to work?
Nov 25, 2013 at 9:23 AM
I did the same but, in my case, the recaptcha works.