Admin Panel Update Error

Topics: Themes
Dec 16, 2013 at 7:47 AM
Hi everyone, I using Blogengine version 2.9 beta,
I want add extension and theme but show a problem message.
Image
Please help me, thanks.
Coordinator
Dec 16, 2013 at 2:52 PM
Application must have write permission on some folders. For extensions, it is "/app_code", for themes "/themes". It is probably trying to upload files but doesn't have write permissions.
Dec 18, 2013 at 9:14 AM
Hi rtur, according this did you think that is possible to change themes, user controls, and widget directories from root to app_data?
Second, I have the same problem of rootturk but when I try to set a blog like AGGREGATOR, can you help or explain how to fix?
Thanks
Coordinator
Dec 18, 2013 at 2:19 PM
No, app_data only for data and moving code there won't work.
I'm only guessing it can be write permission issue. Can be something else completely. No way to tell without looking at the site, checking log file etc.
Dec 19, 2013 at 12:23 PM
I see, infact I have changed reference of themes to App_data\themes and it doesn't work: I get Error 403 forbidden access to CSS files.
Dec 21, 2013 at 3:17 AM
Hi Ildrago and Rtur,

I am getting Error trying to install extension too with version 2.8.1.1

No error in logger

But with Version 2.8.3.1 the same extension installs ok.


So I guess Version 2.8.3.1 fixes the issue.



So solution is to upgrade to Version 2.8.3.1 :)
Mar 3, 2014 at 7:09 AM
I am able to add new content.. but i got an "update failed" when i tried to update any setting in my admin panel. Please reply as soon as possible .
Thanks
Mar 3, 2014 at 7:09 AM
I am able to add new content.. but i got an "update failed" when i tried to update any setting in my admin panel. Please reply as soon as possible .
Thanks
Mar 3, 2014 at 7:22 AM
Hi All,

I have confirm with over 5+ installs of BE 2.9 on our server that just giving /app_data read/write access will not solve BE issues.

In order for BE 2.9 to work you basically have to give your entire website folders read/write access in order to use the Gallery to install things and also
to add content and etc to the website.

I think solution should be a folder structure similar to the current admin menu with "Custom" link.

/app_data
/Custom (Nested Extensions,Themes,Widgets)

/Custom/Extensions
/Custom/Themes
/Custom/Widgets

If Gallery is still going to have /app_code/extensions /app_code/widgets

Then the /app_code need to be nested inside the /Extension or /Widgets folder and not in stand alone /app_code folder

Doing it this way only have to give permission to two folders instead of 5 or more folders

/app_data
/Custom


Also notice that the /API folder also needs read/write permissions and don't know if that can be moved to the /Custom folder and still work?


But I know for fact 100% all of these errors being reported on this forum thread is purely related to the correct read/write permission rights.

I had selectivity added these rights to folders I thought that needed them and still experience issues.

Only when I enabled "Write Permissions" for entire website is when these errors went away.

So I think some sort of re-organization of folders based on read/write permission needs should help with these issues.
Mar 3, 2014 at 7:26 AM
Thanks for the reply. But i have given full permission from my root directory. But i am still getting the same problem . Please Help me
Mar 3, 2014 at 7:29 AM
Do you have Windows 2012 for your server?

I notice Windows 2008 server does not work "as-is" and require configuration from your hosting provider.


Can you give me the URL of your website?

Using FireBug you can look at the network to see the actual errors.
Mar 3, 2014 at 7:32 AM
ok .. my website link is howtoinstall.co.in .. And may be i have windows 8 server. Please get me out of the issue.. :-(
Mar 3, 2014 at 7:38 AM
Hi Amitbaghel,

You have Windows 2012 --> Server: Microsoft-IIS/8.5

So it is a permission issue.


email me at

kbdavis07@yahoo.com Create an Admin account and give me the login information.

I will then check firebug and log to see if there are any errors.
Mar 3, 2014 at 7:45 AM
which login information do you want ? arvixe account or my blogengine account ?
Mar 3, 2014 at 7:55 AM
Hi Amitbaghel,


:)
  1. Your BlogEngine account
If you really want to you can create a peer account for me on your Arvixe account and provide that too.


Its up to you on what you wanted to do.

Providing me both now can save time if I need it any way later on :)
Mar 3, 2014 at 8:00 AM
hi kbdavis ..

Please Wait for some time i am having lunch .. i will be back in some time.
I will give you my blogengine account as well as peer account on arvixe.
Please solve my issue. This is 3rd day having same problem :-(
please fix the issue as soon as possbile..

Thanks for replying on my comments.. I really appreciate you..
Mar 3, 2014 at 8:48 AM
hi davis,
My blogengine username is admin
and pw is amitbaghel and my url is http://howtoinstall.co.in

please help me. And i am making a peer account for you wait for that. First try to solve the issue with the given username and password.

Thanks for helping me


Aug 16, 2014 at 3:11 PM
I had the same issue being described above.
Trying to save, publish or delete a blog entry using the administration area of the site would give the "Update Failed" error.

Solution
On the virtual directory settings for my website, I changed ASP.NET to run under 4.0 (Integrated Pipeline) and this solved the issue.

Hope this helps other.
Mar 2, 2015 at 5:15 PM
Hi I am trying to deploy a fresh version 3.0 on an arvixe hosting and I am getting the following issue. It loads ok on debug mode in the browser but when i deploy using integrated asp.net I get the following errors.


Line 103: if (_initializedAlready) { return; }
Line 104:
Line 105: WidgetZone.PreloadWidgetsAsync("be_WIDGET_ZONE");
Line 106: Utils.LoadExtensions();

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0433: The type 'App_Code.Controls.WidgetZone' exists in both 'c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\3c7331b4\32c0ff71\App_Code.qybqqiui.dll' and 'c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\3c7331b4\32c0ff71\assembly\dl3\2028cd88\0caf0ad9_5053d001\BlogEngine.NET.DLL'

Any ideas please.