BlogEngine.NET and .NET Framework versions...

Topics: ASP.NET 2.0
Jan 3, 2014 at 1:23 AM
Hello...can you tell me if the latest release of BlogEngine.NET version 2.9 will work atop the .NET Framework version 4.0 even though 4.5 is called for? If not, will version 2.8 work? My hosting service is currently on 4.0 and will not have servers available running the higher level framework for a time.
Jan 3, 2014 at 2:45 AM
2.9 requires .net 4.5
2.8 should run on .net 4.0
Jan 4, 2014 at 12:42 PM
Thanks for your feedback rtur. I am giving v2.8 a try. If I understand correctly changes I'll need to make include:
  1. On App Data folder set permissions to include "write" and set property that all children folders/file inherit this setting.
  2. Under IIS management, create a virtual directory, and set as the application root.
  3. Under IIS management, advanced features, set pipeline mode to classic.
Turns out my host must make these changes for me as I do not have access via my/their site control portal. I will reply if I encounter any further issues.
Jan 4, 2014 at 5:15 PM
This video goes over installing 2.9, but 2.8 is very much same process except choosing 4.0 framework. Mode for both integrated, not classic.
Feb 16, 2014 at 4:45 PM
Recompiling 2.9 in .net 4.0 won't work? @rtur What are the reasons behind this?