This project is read-only.

Test mail setting failed

Topics: Controls
Jan 9, 2014 at 7:26 AM
although my contact form work fine, but when I click on admin->setting->Email->Test mail setting, it show failed.
I gave as smtp server, port no:587 and enbled SSL.
Jan 9, 2014 at 1:33 PM
Try port num. 465 with SSL instead of 587.
Port num 25 could be also an alternative with SSL.
Port 587 require TLS .
Jan 9, 2014 at 5:06 PM
I tried all, but not worked, it give failed message.
Jan 9, 2014 at 5:16 PM
Lots of hosts, GoDaddy in particular, will block any port but 25 and will require to use only their own email accounts ( etc).
Jan 9, 2014 at 5:18 PM
but my contact form is working fine, only minor thing is when I click on admin->setting->Email->Test mail setting, it show failed.
Jan 9, 2014 at 5:35 PM
You mean email works fine and just test function displays fail message? That would be odd, the only difference is that email uses whatever saved in settings and test whatever currently filled in the text boxes on email settings page. Which should be the same. But both contact form and test button call the same send email function.
Jan 9, 2014 at 5:44 PM
yes email works fine via contact form, only test function display fail message.
Jan 9, 2014 at 6:05 PM
I download logger.txt, in which it mentioned:"Error sending email in SendMailMessage: Failure sending mail. The remote name could not be resolved: '"
Although i give email id),and click on save button , but save button didnot response, although it show in my Email address fiells.
i think there is some problem in my web file, because i am also unable to add any page via editor,it also show failed.Also not able to change any preinstalled theme.
Jan 9, 2014 at 6:57 PM
Looks like you don't have write permissions on your site folders so you can't save anything.
Jan 9, 2014 at 7:06 PM
I have write permission on my site folders.
Jan 9, 2014 at 7:17 PM
got it, i set as classic mode, i change it to Integrate mode, now email setting display completed, and test mail successfully reach at my mail box.
Jan 9, 2014 at 7:23 PM
Thanks rtur.
Jan 9, 2014 at 7:26 PM
All well that ends well :)