slug pages generate .net runtime error

Mar 13, 2009 at 4:03 PM
I just moved my blog from GoDaddy to Arvixe.  Almost everything works fine.  I can make posts, I can edit posts, I can sort, view my archive, etc.  The only thing I can't do is click on a post title to view the individual post.  When I do that I get a runtime error.  I get the same error when I save a post through the Add_entry.aspx page.  I have write permissions set on the App_Data folder, my post xml files are getting written. 

Any ideas on what might be going on?
Mar 13, 2009 at 4:05 PM
Forgot to say, I'm currently running 1.3.1 with xml for the posts.
Coordinator
Mar 13, 2009 at 7:28 PM
Are there any details in the runtime error you are seeing?  Can you see the post without errors if you retrieve it by clicking on the Permalink?  I'm guessing BE v1.3.1 has a permalink (never used it before).  Can you view the RSS subscription link?
Mar 13, 2009 at 7:43 PM
No, no details, it's the generic .net error page. 

The permalink does not work either. 

http://www.snelsonco.net/blog_backup/

If you click on a post title for example the first one, this is the URL that it uses "http://www.snelsonco.net/blog_backup/post/2009/03/lets-try-again.aspx"  the permalink has a different URL when you hover over it, but it ends up at the same URL as clicking on the title.

I can view the RSS subscription link, but clicking on the post titles give me the same URL as above.  Clicking on the post RSS link doesn't throw errors either.  It still works the same as it did on my old hosting server.


Coordinator
Mar 13, 2009 at 7:48 PM
To get a more detailed error message, you can do as the generic error message suggests.  In your web.config file, within the <system.web> section, add a <customErrors> tag, like:

<customErrors mode="Off"/>

Then you should get a more detailed error message.