This project is read-only.

Restoring Data folder from backup

Mar 31, 2009 at 8:09 PM
I had some configuration problems on a blog which had been running for over 4 months with no issue.  I made a back of the data folder and done a fresh install of the BlogEngine.Net.  I then copied all the data folders back over and set permissions etc. I am now getting a blank page..are there other folders i need to copy?

Mar 31, 2009 at 8:14 PM
Blank page -- you mean a completely blank, white screen in your browser?  Or is the blog there, but there are no posts?

Before copying your backed up data over, did the blog come up in the new installation?

Which files/folders did you copy over from your backup?  Is the version of the old blog installation the same as the new blog installation?
Mar 31, 2009 at 8:26 PM
Edited Mar 31, 2009 at 9:12 PM
thanks for the reply.  Yes I mean completely blank, no error.  I have now manage to get the blog running again using all the vanilla settings...

I have coped over my Data folder but when I login to the admin my data folder seems to be getting in the settings are all default yet when i view the settings.xml i can see my real settings..

To answer your questions...

The blog works prior to me copying the data folder.

I have copied over the entire App_Data folder, then i tried just copying the files within the root of App_Data...

How can i check the blog versions?

Mar 31, 2009 at 8:30 PM
The blog version at that URL is 1.4.5.  The version is in the footer of the blog.  I'm not sure what the version was in your old blog installation.  I don't think the version is recorded in any data files.

When I go to that URL you posted, I see a lot of posts.

I think what you need to do is re-start the application for the settings/data you copied over to get detected.  If you make any small change in your Web.config file (add a space, for example), then the blog should re-read any settings in the App_Data folder.  Right now, I'm guessing the settings are cached and BE isn't aware you copied new settings into the App_Data folder.
Mar 31, 2009 at 9:03 PM
Edited Mar 31, 2009 at 9:51 PM
all the post seemed to have worked no probs...

I'm pretty sure the old blog installation was 1.4.5 as it was installed around December time and the last big release was June...

I will try making a change to web.config an restart the application, when you say restart the application do you mean stop and start the IIS or stop start the blog website

Thanks again for the prompt replies.

Mar 31, 2009 at 9:14 PM
BenAmada much appreciate your comments, making a change to the web config reloaded all my setting correctly and its now running as it should. This would be worth sticking in the trouble shooting section within the DOCS as i had went there first...just a thought.

Thanks again.