Is there a way to show description without [more]?

Apr 8, 2009 at 5:58 PM
I would like to enable a description without the more tag. Is this possible?

Thank you!

Apr 8, 2009 at 6:14 PM
It's possible.  On the Settings tab in the control panel, check the "Only show description of posts" box.

If you're using a recent version of BE, next to that checkbox there is a field that allows you to choose the "Number of Characters" to show.  If you don't have that box, it will default to showing the first 300 characters of each blog entry.  This option will apply to all blog posts.

You can also use a custom description for each blog entry in the "Description" field when composing the blog entry.  When using the "Description" field, you still need to have the "Only show description of posts" box checked.
Apr 8, 2009 at 6:23 PM
Thank you, although I'm not sure I explained myself well. I want to have the description but not the more tag.  I've got the boxed checked, and I also tried the custom description trick. bot of those gave me a description, but I want the description without the tag.

I've tried a couple of things to get rid of it, but haven't had any luck yet.

Apr 8, 2009 at 6:29 PM
I understand.  There's two ways to do this.  The easier way to do this is by adding a new CSS class in your theme's style.css file.  If your blog theme is Standard, then the file will be in the themes\Standard folder, for example.  The following CSS style should work:

.post .text a.more { display: none; }
Apr 8, 2009 at 7:01 PM
Thanks so much for your help! I had tried messing around with breakpost - this is much better!

Apr 19, 2009 at 4:58 PM
Edited Apr 19, 2009 at 4:59 PM
Hi Ben
I want to customize [More...] in Post Editor like wordpress .I see breakpost in Settings but it isn't suitable for me.:)
Apr 19, 2009 at 5:52 PM
Hi Joey.  I'm not sure how More works in WordPress ... so I don't know what you'd like to do with it.  The code for it is in the BreakPost.cs file in the App_Code\Extensions folder.
Sep 10, 2009 at 3:55 PM


.post .text a.more { display: none; } is not working for me.

I have checked "Only show description of posts" in the admin panel. The posts show with descriptions and [more...] tag. I don't want this [more] tag. please help!

May 17, 2011 at 1:48 AM

Probably too late for you now, but if anyone is looking at this in the future (like I was) here's how I did it:

In my site.master I have a reference to jQuery. At the bottom of the file I added

<script type="text/javascript">
    $( function() {
        $( "a:contains('[More]')" ).hide();
    } );