Can not config any things on Admin panel 2.9.1

Topics: Business Logic Layer, Controls
Feb 1, 2014 at 3:11 AM
Edited Feb 1, 2014 at 3:19 AM

As Subject, I can update post or config any things on Admin panel. I updated version 2.9.1 BE.
and set write permission on AppData but nothing change.

All work will ok If I run on local. Problem when I upload to host.

Please help, thanks
Feb 1, 2014 at 7:14 AM

anyone can explain for me ?

Feb 2, 2014 at 10:03 AM
I have the same problem... if I want to edit the post or add a category/tag it comes the same error... no logging to understand what it is the cause!
Feb 2, 2014 at 9:35 PM
Hi All,

It comes down to your permission levels on your folders server side.

Create a blog here:

You see you can create posts ok because permissions are set correctly.
Feb 3, 2014 at 2:19 PM
No, I store the post in sqlserver and so I don't think is a permission problem.
And why it saves correctly the first time and then fails the following saving ?
Feb 4, 2014 at 10:32 AM
Edited Feb 4, 2014 at 10:39 AM
Hi All,

I have the same problem (Framework 4.5 / Windows 2008 R2 / SQL Server 2012) with a fresh new blog 2.9.

I found that Request Filtering may interfere with Update and Delete as SQL Injection rule may block requests containing the words update, delete. The webservice used to delete a user responds to xxxx/api/UserService.asmx?op=Delete (it should be clever to not use the value Delete for op parameter!!!) where xxxx stands for the root URL of your blog.

Anyway after removing the filtering rule a manual call to the service to delete admin user gives this error:
<Message>No HTTP resource was found that matches the request URI 'xxxxx/api/UserService.asmx/Delete'.</Message>
<MessageDetail>No type was found that matches the controller named 'UserService.asmx'.</MessageDetail>

I guess the problem deals with URL rewriting... or again with 'Delete' in the URL.
Feb 4, 2014 at 12:41 PM
how do you remove the filter ?


PS anyway, deleting comments I don't have any problem...
Feb 4, 2014 at 2:52 PM
Open Administrative Tools / Internet Information Services (IIS) Manager, select your web from the left pane then in the right pane (under IIS) check if there is any rule set for Request Filtering and/or search for some <requestFiltering> section in your Web.Config:
                    <-- HERE -->
I can Add and Delete comments from the blog page BUT can't delete comments from the admin panel...
Feb 4, 2014 at 3:08 PM

With problem can not update or config, how we fix it ?

can you help?
Feb 4, 2014 at 3:43 PM
There are basic requirements server must meet:
  1. .net 4.5 / integrated mode for app pull.
  2. Full trust (you might need to set it in web.config changing from "medium" and uncommenting, depends on server configuration).
  3. Write permissions on app_data folder.
If it is still not working, please clearly explain your situation - version you are using, any modifications from plain install, anything in the error log, steps to reproduce the error etc. More you give, more you get.

If you run into issue with your host, you probably should:
  1. Install web version locally, no modifications.
  2. Push to host, no changes.
    If this doesn't work, obviously something different on the server. If you have full access, you can troubleshoot comparing local and remote site. If you host and don't have full access, you need to confirm with your host that server supports requirements outlined above.
Feb 5, 2014 at 7:55 AM

Our versions are:
  • Windows Web Server 2008 R2 SP1 (6.1.7601) / IIS 7.5
  • .Net Framework 4.5.1 (v4.0.30319 Release 378758)
  • SQL Server 2012 (11.0.3128.0)
  • BlogEngine as unzipped excepted credentials to access the SQL database in Web.Config !
Public site is showing normally (either XML or SQL mode), rating and commenting are working both.

Don't know if it serious but Fiddler shows some 404 errors for ~/admin/%7B%7Bpackage.IconUrl%7D%7D, ~/admin/%7B%7Bitem.IconUrl%7D%7D...

The serious issues arise using admin panel (same issues arise using XML or SQL): we may create anything but can't edit nothing (error alert box Update failed).
  • Fiddler shows an error 405 Method Not Allowed for ~/processchecked/publish and ~/processchecked/unpublish ({"Message":"The requested resource does not support http method 'GET'."})
  • Error 405 for ~/api/users/update/item when trying to edit a freshly created user. A few minutes after, the log file widget shows an error "04/02/2014 18:39:59 Error editing profile: Object reference not set to an instance of an object" but today are on the 5th february and it's around 9:30 AM...
  • Error 405 for ~/api/users/processchecked/delete~ when trying to delete the admin user...
  • Error 405 for ~/api/posts/update/foo when trying to update a post...
It's why I thought the problem could be with rewriting.

Setting trust level to Full doesn't help, it's worst: when browsing to Custom an alert box shows telling "Error loading packages" (Fiddler says 404 for ~/api/packages?filter=PackageType+%3D%3D+%22Extension%22+and+Location++!%3D+%22G%22&order=LastUpdated+desc&skip=0&take=0), when browsing to Dashboard we get a large collection of errors of tyhis type.
Feb 5, 2014 at 2:21 PM
It looks like in your case IIS does not allow "put" and "delete" methods, so you can get and post but not update or delete. Here are some things you can try.
Feb 5, 2014 at 6:01 PM
Edited Feb 5, 2014 at 7:58 PM
I tried all the tricks but got no success :-(

I installed to a W2012 production box and there it worked like a charm. I suppose that the long story of our W2008 dev box...

Thanks for your help Rtur :-)

EDIT : Users who suffer from this type of issues should check if URLSCAN is installed on their box and what are the settings for AllowVerbs/DenyVerbs...

; The verbs (aka HTTP methods) listed here are those commonly
; processed by a typical IIS server.
; Note that these entries are effective if "UseAllowVerbs=1"
; is set in the [Options] section above.



; The verbs (aka HTTP methods) listed here are used for publishing
; content to an IIS server via WebDAV.
; Note that these entries are effective if "UseAllowVerbs=0"
; is set in the [Options] section above.

Feb 7, 2014 at 6:30 AM
Dear All,

I believe this problem happen because of basic requirements server:
  • .net 4.5 / integrated mode for app pull.
  • Full trust (you might need to set it in web.config changing from "medium" and uncommenting, depends on server configuration).
  • Write permissions on app_data folder.
I debug and config IIS at local so it support http method 'GET' ,'SET', ...

I contact with provider hosting and ask them config exactly above requirement. All problem's gone.

Thanks rtur and all of you.
May 31, 2014 at 6:54 AM
I has the same problem with blog 2.9.

Im trying to check server requirements environment.Set the full trust level in web.config, Set full permission for app_data folder but the error not fixed.

Please help!
Jun 13, 2014 at 4:39 PM
I had the same problem, the only resolution was too turn-off WebDAV and remove our website's (not BlogEngines) URL Rewrite rules. This allows us to save/edit posts but we need to utilize our original websites URL rewrite rules so we're still looking for a better solution.
Jun 13, 2014 at 6:05 PM
Our problem was resolved by stopping web.config inheritance:
Jun 23, 2014 at 9:30 AM
pray4Mojo14 wrote:
Our problem was resolved by stopping web.config inheritance:
I add <location path="." inheritInChildApplications="false"> to web.config file but problem not resolved.

Please help!Thanks!
Aug 16, 2014 at 2:04 PM
I had the same issue being described above.
Trying to save, publish or delete a blog entry using the administration area of the site would give the "Update Failed" error.

On the virtual directory settings for my website, I changed ASP.NET to run under 4.0 (Integrated Pipeline) and this solved the issue.

Hope this helps other.