Newsletter not sending again!

Feb 8, 2014 at 2:28 PM
I am using BE 2.8.10.2 with SimpleBlog. I have the latest newsletter code installed. The newsletter just works when it wants too. I am using the default page with code installed to make it look like a front page and not a blog. The Newsletter is installled at the bottom in Widgetzone 2, I have tried it on a standalone Notify page without success, on a page set as the front page without success. Is the theme the problem, I just need a Newsletter that works without issues. Thank you.

sahcinfo.org
Feb 8, 2014 at 5:08 PM
I was under the impression that the default Newsletter would also send out a page change when publish is unchecked, save is clicked, publish is checked, save is clicked again. I thought a page change would work the same as a new post. Any thoughts, it is not working that way for me. Thank you.
Feb 9, 2014 at 10:25 PM
Edited Feb 9, 2014 at 10:30 PM
Any help here? Newsletter will not send on new post now.The only way I can get it to work is by deleting the Newsletter Widget from the page and then add it back again.
Feb 9, 2014 at 11:03 PM
Hi Jerry,

Had you tried to install Elmah?

I find Elmah to be very useful in finding the exact error in areas where you are having problems.
Feb 10, 2014 at 2:48 PM
No I haven't tried to install Elmah, could you brief me on the installation again, I need to have a working Newsletter, thanks.
Feb 12, 2014 at 3:36 AM
Hi Jerry,

I am working on a NuGet Package for Elmah for BE so it can be installed from the Gallery, but if you can't wait here is the directions:


From Discussion at the very very bottom:

https://blogengine.codeplex.com/discussions/250335

Update on installing Elmah on BE 2.7 with Nuget

Here is the web.config file to get it to work:

This is at the very bottom of the web.config file around line 250

Items in bold is the things that needs to be changed.

<elmah>
<!-- See http://code.google.com/p/elmah/wiki/SecuringErrorLogPages for more information on remote access and securing ELMAH. --> <security allowRemoteAccess=__"false__" />

</elmah>
<location path="admin" inheritInChildApplications="false">

<system.web>
<httpHandlers>
<add verb="POST,GET,HEAD" path="__/admin/__elmah.axd" type="Elmah.ErrorLogPageFactory, Elmah" />
</httpHandlers>


<authorization>
__<allow roles="Administrators" />__
<deny users="*" />  
</authorization>

</system.web>
<system.webServer>
<handlers>
<add name="ELMAH" verb="POST,GET,HEAD" path="__/admin/__elmah.axd" type="Elmah.ErrorLogPageFactory, Elmah" preCondition="integratedMode" />
</handlers>
</system.webServer>

</location>



To make it easier to access from with in the admin panel edit this file:

Web.sitemap

Its in the root directory

add this line to the very bottom of the list of links:


<siteMapNode url="~/admin/elmah.axd" title="Elmah" rights="AccessAdminSettingsPages" description="" />

Now you can access Elmah from within the Admin panel.

Feb 12, 2014 at 8:57 AM
Feb 12, 2014 at 1:15 PM
Link not working to the post.
Feb 12, 2014 at 7:37 PM
Hi Jerry,

http://blog.bloggersonline.com/post/be-elmah-nuget

Is now working, had same issue with the time differences, so it was not showing up as being published yet.

The actual package is at:

https://www.nuget.org/packages/Elmah.BlogEngine.Net/1.0.5

Just in case some how the post link does not work.
Feb 16, 2014 at 2:00 PM
Edited Feb 16, 2014 at 5:10 PM
I installed elmah.blogengine.net and had to uninstall it as I could not navigate the admin panel. The Newsletter only works if I uninstall the widget and then reinstall it, at the present time I have it installed on a standalone page, it preforms the same way if it is on the default page or on a front page. It also only works with a new post and not a new published page.
Feb 20, 2014 at 12:02 AM
Is there any hope for a Newsletter that will work as it should. I thought that the Newsletter would work for any new page or a page that has changes made to it and saved/published. The only way I can get the Newsletter to work with a new post is to delete it and reinstall the widget again. Can anyone help with this issue, thank you.
Feb 20, 2014 at 12:49 AM
Edited Feb 20, 2014 at 12:53 AM
Hi Jerry,

Following your discussion here and see you are using BlogEngine.NET 2.8.0.2 with SimpleBlog.

Had you tried using a newer version to see if it had been fixed.

Looking at the source History I see the following:

106a2c6c1983 by rtur (28 downloads) Jan 15 8:47 PM
  • Newsletter widget to work with page set as frontpage
  • Fixed issue with slug increments on post save
(2.9.0.9)

If I were you I would try at least Version 2.9.0.9 and higher to see if you have the same issue.

You can test it out live yourself here:

http://demo.bloggersonline.com/newsletter

Login test1/test1

Or create your own blog by going here:

http://demo.bloggersonline.com/Account/create-blog.aspx

It is using version: BlogEngine.NET 2.9.1.6

This way you don't have to mess with it on your server.

See if you can get it to work like what you are trying to do on your own website.

Elmah is set-up to catch any errors so we can see what is actually happening.

The demo website mail is set-up to send email out too.


So give it a try to see if it works.

Then from there would work on fixing this issue for you once and for all.
Feb 20, 2014 at 1:02 AM
I am using this:

106a2c6c1983 by rtur (28 downloads) Jan 15 8:47 PM
Newsletter widget to work with page set as frontpage
Fixed issue with slug increments on post save
Feb 20, 2014 at 1:08 AM
Your Website is using:

Powered by BlogEngine.NET 2.8.0.2

http://sahcinfo.org

It is not using version 2.9.0.9


Screenshot:

http://awesomescreenshot.com/0da2dohlf6
Feb 20, 2014 at 1:18 AM
Edited Feb 20, 2014 at 1:19 AM
I am using the Newsletter from the source code of 2.9, it was supposed to fix the issues. The server I am on at Arvixe does not support 2.9, we tried it and they are supposed to be in the process of moving me to a new server at sometime in the near future.
Feb 21, 2014 at 8:49 PM
Edited Feb 21, 2014 at 9:26 PM
Hi Brian,

I created a test blog, added 2 email addresses to the Newsletter, created a new post and edited the testing page, saved and published it and did not receive any notification for the post or the page edit. Setup the email settings saved and the test worked fine but it won't allow me to keep the email settings to test a new post or edit the test page I setup so no notification was sent out.

Thanks for the testing site, if the email settings would save I could test some more.

Jerry
Feb 22, 2014 at 2:00 AM
Hi Jerry,

I am noticing that different versions of BE for some reason the newsletter is not working.

I know for fact that BlogEngine.NET 2.8.1.1 works ok "as-is" in terms of sending out the newsletter for posts.

But, for some reason versions above that seems not to be working.

In my spear time I am trying to figure out this issue.

Will post updates here on what I find and the solution.


Also the following settings:

private const bool SendEmailsForPosts = true;
private const bool SendEmailsForPages = false;

https://blogengine.codeplex.com/SourceControl/latest#BlogEngine/BlogEngine.NET/widgets/Newsletter/widget.ascx.cs

Needs to be set from within the Widget from the edit section of the widget and not hard coded in the widget.ascx.cs file.

Since now .cs files for Web app are compiled.

Will do this myself after find solution to newsletter issue or someone else can do it to if they wish :)

Just keep update here.



As of now I am just working on finding the solution.

Anyone else that wishes to help please do and post your findings and solutions here.
Feb 22, 2014 at 1:37 PM
Edited Feb 22, 2014 at 2:51 PM
Another edit!

The Newsletter is now working without deleting it first, I will stick with 2.8.0.2 until the Newsletter issue is worked out with 2.9.



Another edit!

I have the Newsletter sending out post and page updates, the only glitch is that I have to delete the widget and reinstall the widget before I do post and page updates for it to work successfully.


Edit!

I changed private const bool SendEmailsForPages = true; but it still does not send a page update, a new post is working.


Please disregard, I found it.


Where can I put this in the widget.ascx.cs for a single stock 2.8 Newsletter and enable it to also send on a page update? Thank you.

private const bool SendEmailsForPosts = true;
private const bool SendEmailsForPages = true;
Feb 22, 2014 at 4:24 PM
The Newsletter just works when it wants to, I am back to deleting the widget, reinstalling the widget in the footer widget zone and then doing the publishing of a post or page update to enable it to send out notifications. Still a pain to deal with.