Not able to even install on the Server

Topics: ASP.NET 2.0, Controls
Jun 5, 2014 at 4:28 PM
Hello guys ,

Well i have followed the instructions in documentation area about how to install this Blog Engine on Server but i have faced a problem that sometimes it says to change the web.config file

from original to

<system.web>
<customErrors mode="Off"/>
</system.web>

I did then it says 500 Internal Error ..

Now i am totally screwed up

Do help me out with simple steps to make it done ......
Jun 5, 2014 at 4:51 PM
Hi Nkwebart,

We need more information in order to help you out here :)
  1. What version of BE are you trying to install?
  2. Is it the source version or Web version?
  3. How did you deploy it to your server?
A. FTP
B. Web Deploy
C. Web Deploy Package

Some things to try:


Most common error is not having read/write permissions on your web.config file.

That happens sometimes when using Web Deploy.


Some .Dll is missing from the /bin folder

If using source version then web grease or Newton Json might be the issue.
Jun 5, 2014 at 4:58 PM
I am running on MS 4.0 and that was a Web Version of files .

How is that possible that .dll file can be missed because i just download and uploaded it direct on the server and all the files were extracted correctly .

I have uploaded the files via FTP
Jun 5, 2014 at 5:00 PM
Please Check the Error what i am getting every time
<!-- Web.Config Configuration File --> <configuration>
<system.web>
    <customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File --> <configuration>
<system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Let me know if anything can be happened
Jun 5, 2014 at 5:52 PM
Hi Nkwebart,

What version of BE are you trying to install?

BE 2.5 and above requires Asp.Net 4.5 in order to run.

The error you are getting is a very generic error, it is telling you to turn on remote errors so you can see what the actual error is.


What you can do is zip your wwwroot folder as is.

Very important to Zip, If you just do FTP file by file you are going to get errors.
  1. It takes much longer
  2. You can miss files.
Then once you got the zip on your computer, unzip and open in Visual Studio.

You will see the actual error then.