BE 2.9 on Arvixe not working, receiving this error!

Jun 19, 2014 at 3:44 PM
I installed BE 2.9 on my Arvixe server from the web gallery and am receiving this error, any help would be appreciated. Thank you.
Server Error in '/' Application.
Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0246: The type or namespace name 'HttpResponseMessage' could not be found (are you missing a using directive or an assembly reference?)

Source Error:


Line 32: }
Line 33: 
Line 34: public HttpResponseMessage Get(string id)
Line 35: {
Line 36: try


Source File: e:\hostingspaces\jsdean43\sahcinfo1.sahcinfo.org\wwwroot\App_Code\Api\PagesController.cs Line: 34 
Jun 19, 2014 at 9:46 PM
You are more likely missing the

System.Net.Http.dll


File.

Check your /bin directory make sure that is in there.


If it is there make sure that /bin directory is read able.
Jun 20, 2014 at 2:54 AM
File is there and bin directory is readable.
Jun 20, 2014 at 3:05 AM
Hi Jerry,

I did not notice your App_Code folder :)

\wwwroot\App_Code\Api



If you are installing BE 2.9 that folder is no longer should be on the server at all.

It is a compiled Dll now.


BlogEngine.NET.dll


Screenshot:

http://awesomescreenshot.com/0da30fod86
Jun 20, 2014 at 3:30 AM
Hi Brian,

I installed it from the server web gallery, you would think it would work ok doing that, I think I will download it and publish it and see what happens, thanks.

Jerry