Admin troubles after install on GoDaddy

Jun 24, 2014 at 5:54 PM
I've registered some hosting on GoDaddy... and Installed BlogEngine.net in to a sub-domain on my site. The install goes well.. I log in as the Admin, set the write permissions on the App_data folder... then try to do anything admin section (set up users, profile etc...) and I get an error page "Ooops! An unexpected error has occurred."

where can I find what the error is? so that I can fix it?
Coordinator
Jun 24, 2014 at 6:34 PM
Set custom errors to "Off" in the web.config to see actual error instead of "oops" one.
Jun 24, 2014 at 7:23 PM
hrm, so it throws a security exception like this:

Security Exception
Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:



Line 4: @{
Line 5: App_Code.WebUtils.CheckRightsForAdminPagesPages(false);
Line 6: string loginUrl = Href(Utils.RelativeWebRoot + "Account/login.aspx");
Line 7: var userRights = Security.CurrentUserRights().Select(r => r.Flag).ToArray();
Line 8: }
Coordinator
Jun 24, 2014 at 9:14 PM
You need to set full trust level. According to GoDaddy:

To Change Your Trust Level
  • Log in to your Account Manager.
  • Click Web Hosting.
  • Next to the hosting account you want to use, click Launch.
  • At the bottom of the section of the domain hosting you want to use, click the downward-facing arrow.
  • Click ASP.NET Settings.
  • From the CAS trust level menu, select the settings you want, and then click OK.
Probably can also set in web.config if GoDaddy allows it.
Marked as answer by jeffpriz on 6/25/2014 at 11:28 AM
Jun 24, 2014 at 9:41 PM
That did the trick! Thanks SO much!
Jun 28, 2014 at 7:47 AM
I am not seeing the 'downward-facing arrow'. Is it in the CPanel or classic hosting panel?
Jun 28, 2014 at 4:26 PM
I posted how to do it on my blog. Blog.oneluckidev.com. See if that helps..

Sent from my Windows Phone

Jun 28, 2014 at 8:25 PM
Thanks jeffpriz, but I am on a shared hosting and it doesn't have the Plex manager panel.
Jan 17, 2015 at 2:07 AM
Thanks for the heads up on trust level = Full!
set in web.config did the trick for me.
Mar 9, 2015 at 8:28 PM
rtur wrote:
You need to set full trust level. According to GoDaddy:

To Change Your Trust Level
  • Log in to your Account Manager.
  • Click Web Hosting.
  • Next to the hosting account you want to use, click Launch.
  • At the bottom of the section of the domain hosting you want to use, click the downward-facing arrow.
  • Click ASP.NET Settings.https://blogengine.codeplex.com/discussions/549553#
  • From the CAS trust level menu, select the settings you want, and then click OK.
Probably can also set in web.config if GoDaddy allows it.
i already dit it CAS- Full trust
but still have same problem