This project is read-only.

Pages not publishing.

Jun 25, 2014 at 4:37 PM
Hello all.

I have a site hosted on GoDaddy. I've configured it, it seems to work fine. Its live and running and I've started blogging.

Yesterday I wrote a blog post which I noticed was not visible unless I was logged in as Admin. I played about with un-publishing and re-publishing the page and eventually (although I'm not sure what I did) it is now visible to anonymous users.

Today I wrote another page and no matter what I try it wont publish to anonymous users. I did 4 other 'test' pages with different things on each, none of which published properly. I've tried un-publishing and re-publishing as both admin and the user (who is also an admin) but still nothing.

I've spent ages setting this up, customising it and writing the first blog, tieing it in to twitter and configuring that I could really do with not having to uninstall and re-install it.

Any advice?

It is installed at the root of my hosted space. I am very new to blogging and websites so please explain things to check as well as you can.
Jun 25, 2014 at 6:13 PM
Go to post settings and set publish date to one day back, this should fix it.
This can happen if server time differ from your local time, you need set time zone in settings to compensate difference.
Jun 25, 2014 at 6:57 PM
Edited Jun 25, 2014 at 7:06 PM
Thanks, I've been through all the settings I can see and can find no such setting to set a publish date. Care to elaborate how to navigate to this setting? I'm using

EDIT: Is it server time offset? Currently set to 0 should I set to -1?

EDIT2: Tried -1 and 1, no change.

EDIT3: Found it, navigate to page, edit, click settings top right hand side, settings drop down, change date as instructed by rtur. Thanks!
Jun 25, 2014 at 9:55 PM
Offset is in hours, so you would use bigger numbers like 10 or -10 and then narrow it down. And this might work only for newly published posts, not updates.