This project is read-only.

Cannot login to primary blog after upgrade to BE3.0

Jul 11, 2014 at 6:01 PM
I had a BE2.9.2.9 (using own build from source) site with a primary blog with a number of child blogs. The primary blog is used for aggregation.

After upgrading to BE3.0 (web package download), I cannot login to the parent/primary blog, but can login to all the child blogs OK. All other functions seem OK

I have tried logging in as the admin account (a name common on all blogs) and admin2 - unique to the parent blog. I am confident the passwords are OK. Both fail to login on BE3.0

The installation is making use of SQL, so I used SQL profiler to see what query was being run, but can see no access on the be_users table so assume some caching is being done. So not sure how to diagnose this any further.

If I revert to I can login with the same passwords. So I assume this is bug in 3.0
Jul 13, 2014 at 3:59 PM
I found the problem. I had not set the default membershipprovider to DBmembershipprovider.

Strange thing was it worked fine for all the blogs other than the parent one.