This project is read-only.

BlogEngine 3.0 dashboard error

Topics: Business Logic Layer, Controls
Jul 16, 2014 at 1:46 AM
When i try to enter in dashboard admin page, it redirects to login page. All other tabs such as Blogs, Content, Custom, Users, Configurations is working fine, but i can't access dashboard page. I made a new database in SQL Server, but i still not succeed. How can i fix it?
Jul 16, 2014 at 4:51 AM
Notes for version 3.0
  • Version 3.0 added few new rights, go to admin -> users -> roles, select "administrator" and make sure all rights are checked for this role.
  • Switch to new gallery under custom -> gallery, in gallery settings add new feed pointing to "" and set it as default.
Jul 16, 2014 at 3:43 PM
i have the same issue. Upgraded by hand and just see two roles (administator and editor) when i try to add editor role i get update failed.
Jul 16, 2014 at 4:23 PM
dsmits wrote:
just see two roles (administator and editor) when i try to add editor role i get update failed.
If you already have editor role and trying to add another, it should fail. Sometimes after upgrade things kept in the cache, you might need to clear browser cache including cookies. Also if you can post screenshot displaying your issue it can help.
Jul 16, 2014 at 7:11 PM
i cleared my browser cache and tried to go to users again to add me to editors, still only administrators was checked and editors unchecked but can't add editor. When i try to add a new user getting an error too.

where you want to have a screenshot of?
Jul 16, 2014 at 8:21 PM
Do you use DB or XML? If DB - did you point membership/role providers to DB after upgrade? Any errors in App_Data/logger.txt?
Jul 16, 2014 at 8:29 PM
xml, and no error in logger.txt

i fixed the dashboard access by assigning the adminstrator role more rights.
Jul 17, 2014 at 2:52 AM
I've cleared the cookies and cache but still not succeed. I just can see administrator and editor in roles. When i use XML works fine, but when i use DB i cannot access the dashboard.
Jul 17, 2014 at 3:02 AM
comparing the roles in xml file with the roles in the DB script, i think that the db does not have all roles. I will make some testes and then i post my results
Jul 17, 2014 at 3:57 AM
Edited Jul 17, 2014 at 6:36 AM
I've already insert the rights ViewDashboard, ManagePackages, ManageThemes, ManageExtensions in the new DB that i created for test and still couldn't see admin dashboard
Jul 17, 2014 at 4:16 AM
I forgot to inset the rights in the table RightRoles...

the following codes, resolved my problem... Its interesting inserting it in the MSSQLSetup3.0.0.0 script
insert into [dbo].[be_Rights]
('27604F05-86AD-47EF-9E05-950BB762570C', 'ViewDashboard'),
('27604F05-86AD-47EF-9E05-950BB762570C', 'ManagePackages'),
('27604F05-86AD-47EF-9E05-950BB762570C', 'ManageThemes'),
('27604F05-86AD-47EF-9E05-950BB762570C', 'ManageExtensions')
insert into [dbo].[be_RightRoles]
([BlogId],[RightName], [Role])
--('27604F05-86AD-47EF-9E05-950BB762570C', 'ViewDashboard', 'Administrators'),
('27604F05-86AD-47EF-9E05-950BB762570C', 'ManagePackages', 'Administrators'),
('27604F05-86AD-47EF-9E05-950BB762570C', 'ManageThemes', 'Administrators'),
('27604F05-86AD-47EF-9E05-950BB762570C', 'ManageExtensions', 'Administrators')
Aug 6, 2014 at 9:58 PM
Edited Aug 6, 2014 at 9:58 PM
I'm experiencing this in a new install of BE 3.0 going against the DB.

When I login and click the dashboard I immediately get bounced back to the login page.

Is there going to be a fix released for this or is there some fixed series of steps to remedy the problem?
Aug 7, 2014 at 6:21 AM
I applied xSlayper's DB updates and it fixed the problem for me. Thanks :-)
Nov 17, 2014 at 11:45 AM
By running the two SQL Statements from xSlayper, solved this problem for me too! Thanks.
Dec 5, 2014 at 12:21 AM
I had the same problem. When I tried to select all the Roles I got an error "Failed to save rights". I am using XML not SQL. I ended up copying the rights.xml file from the Zip and overwrote the migrated file from v2.9. The elements did not exist in the 2.9 version.

I am now worried about what other changes in the XML files there are.
Feb 23, 2015 at 4:56 PM
Thank You , it did work for me. By default the Dashboard wasn't checked.
Feb 26, 2015 at 3:59 PM
I have a fresh install of 3.1, made the database changes above, but still no dashboard access. When I try to grant access to the "view dashboard" to the "administrators" role via the roles screen, I only get the "Failed to save rights" message. In other areas, these messages resulted from attempts to write to the XML files rather than the DB. It appears that the web.config has a lot more options in 3.1 than 3.0 so this was a challenge, as I have been fighting all the way with it still trying to use the xml files. I have checked the logger.txt, and there are no entries for this error. Any other ideas? Thanks.
Feb 26, 2015 at 4:23 PM
Correction, it took a while for the db changes to propagate back to the application. It is now working with the above changes. Thanks anyway!
Apr 29, 2015 at 1:18 AM
I was able to correct the problem by using the role tabs to manually add the missing abilities to the Administrator Role.
May 8, 2015 at 6:47 PM
I also was able to solve the problem by adding the View Dashboard permission to the editors role, which then propogated to the administrators role.