This project is read-only.

delete/put api not found on BlogEngine 3.0

Topics: ASP.NET 2.0, Controls, Themes
Jul 24, 2014 at 2:18 PM
hi, i recently downloaded blogengine 3.0 it works perfectly on local host.
however when i upload it on the server it cant save or delete things.
in fact it can only find urls with POST method all other http methods will face 404 not found.

same question was asked on stackoverflow but still having no answer.

Jul 24, 2014 at 3:13 PM
This sometimes happens when WebDAV module configured to run for all PUT/DELETE requests in machine.config for your web host.

Try to remove it for your application in web.config:
        <remove name="WebDAVModule" />

        <remove name="WebDAV" />
Jul 24, 2014 at 4:44 PM
Edited Jul 24, 2014 at 4:51 PM
thanks alot rtur for the reply.
i`v tried your solution and removed the WebDavModule from both handlers and modules section but still getting same result.
any help is appreciated.
Jul 24, 2014 at 4:51 PM
Edited Jul 24, 2014 at 4:52 PM
Could be something else specific to your server configuration. On stackoverflow lots of related questions with answers, like this one or this. Problem is, it is very dependent on environment - what modules installed in IIS, what allowed/blocked in machine.config, what .net versions used, on and on. So what works for one does not work for other.
Jul 24, 2014 at 7:09 PM
i`v tried all solution on those links, it still dosnt work.
any other idea ?
Jul 24, 2014 at 8:24 PM
Edited Jul 24, 2014 at 8:26 PM
I can look at it later tonight if you send me your site access info (admin login and FTP account to edit web.config).
Without full site access, I have no idea what is going on. Generic 404 not helping.

One thing obvious is to check permissions under settings/tools/permissions, if not yet.
Jul 25, 2014 at 9:04 AM
i fixed the issue.
the problem came out that my site IIS was on 4.0 and not 4.0(Integrated Pipleline) and it was done by some novice employee in there.
i changed it to 4.0(Integrated Pipleline and it works perfect.
any way thanks dear rtur.