This project is read-only.

V 3.0 Contact Form Error

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Aug 7, 2014 at 6:57 AM
I'm getting the following error when submitting the contact form (Recaptcha is enabled - but I still cannot find where to update the keys):

Sorry, but the following occurred while attemping to send your message: Value cannot be null.

Parameter name: Challenge220|kpM5cHUbaDtFPXfIXOVgReGHvDzoA4Lf+aYmsQsyU3GAzlm2kXKe0wNyO8htwQGNpuvTxoNtkuDQctBGMG9fAa9noX/t9baSW2PO27Xzbolp0XDJjsrG/cjlePtpEL4c6fd+FhffqIbgQ38Xfs2SJkocbsquNqOiFXiDWVHLLLq2oq5wyGJTHhrYZsAhQmIUDDNpEjx00zJoVJiQNXcbZZ8PazQ=
Aug 7, 2014 at 3:08 PM
Click title in any list to get to details/properties. In this case, click recaptcha title in extensions list under "custom" tab.
Aug 7, 2014 at 3:11 PM
Edited Aug 7, 2014 at 5:09 PM
Thanks rtur, managed to update the keys. However, I'm still getting the same error.

When this happened the last time it was due to an incorrect CDN reference. But I noticed that was fixed in the core library.

Any ideas?
Aug 7, 2014 at 6:41 PM
This is the blog in question:

Can anyone figure out what's causing this callback error? Contact form is currently unusable :-/
Aug 7, 2014 at 6:48 PM
I'll check this later today, don't have access to PC right now.
Aug 7, 2014 at 6:50 PM
Thx rtur, much appreciated :-)
Aug 7, 2014 at 9:34 PM
I don't see a recaptcha on your contact page.

There is actually a problem in loading the recaptcha javascript file. The response is:
var RecaptchaState = {'programming_error' : 'Input error: Invalid referer'};
A google search for that error brought this up:

Try logging into your recaptcha account and making sure that is allowed.
Aug 7, 2014 at 9:42 PM
Edited Aug 7, 2014 at 9:55 PM
Hi fstanek,

Thanks for the feedback.

I have double-checked the Recaptcha keys and they are correct. Subdomain is supposed to work for same set of keys as regular domain.

In BE admin, on the Extension page, all checkboxes are disabled even though I'm logged in as admin. Is this supposed to happen? When I click view log, the modal is broken. So when I manually navigated to the log URL in separate browser window (, BE cannot find the page.

I have also checked the option to show Captcha for admins but I still see no Captcha whether I'm logged in or not.

All this has been in FF v 31.0
Aug 7, 2014 at 10:40 PM
I'm really not sure what's going on with your reCaptcha...

I can see that it does work if I request it manually @

However, when the request comes from your blog, it fails.

There used to be a "global" setting, but it was removed about two weeks ago by Google (!topic/recaptcha/xj3RfDNiGBc)

Maybe try creating a key for your specific subdomain? I know their help states that you can use subdomains with a single key, but their help also states that there is a global key, and that's obviously wrong.
Aug 8, 2014 at 12:25 AM
I never used global keys, I set up keys for each site.

In this case, the parent site ( is not completed - it's just a landing page with no contact form at this stage. These keys have been set up specifically for the sub-domain

I have just re-created the keys using the top level domain only, and both sub-domain and top-level domain, separated by a comma. Still no luck.
Aug 8, 2014 at 5:19 AM
Edited Aug 8, 2014 at 5:58 AM
fstanek is right, the link to stack overflow discussion shows exactly this issue. I am able to use recaptcha in VS project and published to localhost, but deployed to website with no code changes throws same "invalid referrer" error. Unfortunately recaptcha website itself don't let me add new entry, displaying "oops come again later" error. Will try it again tomorrow, but it seems pretty clear you need add website per domain. Sub-domains are tricky, I'm trying to avoid using them, but you might need to specify sub-domain for a separate key pair.

Update: yes, adding new website to recaptcha account provided new private/public keys and using them seems to fix the issue.
Aug 8, 2014 at 7:56 AM
Hi rtur,

I've set up fresh keys but this will not work.

How do I disable Recaptcha when all the checkboxes are disabled?
Aug 8, 2014 at 3:12 PM
As I mentioned in post above, you might need add "" to recaptcha account. Not top domain etc, literally "". What checkboxes? To disable extensions, click it then clear "enabled" and save.