This project is read-only.

BlogEngine 3.0 on Windows 2008 R2 500 Internal Server Error

Aug 13, 2014 at 5:03 PM

I have setup a VM on Microsoft Azure running Win 2008 R2 - IIS 7.5. .NET 4.5 is installed.

After installing the web version of BlogEngine 3.0 I get 500 Internal Server Error. No sub code no error logged nothing.

I have set the entire blog directory to write access for guests, users and the app pool identity which is IIS_IUSRS. I also tried simply setting the app pool identity to the local admin.

The app pool is set to integrated mode and .NET v4.0 (note above I do have 4.5 installed).

I wonder if there is a prerequisite I have not noticed in the installation procedure. Any information that helps me get this platform up and running will be appreciated.
Aug 13, 2014 at 6:28 PM
Have you look at troubleshooting section in docs? Also install video might help if you haven't seen it.
Aug 13, 2014 at 6:42 PM
rtur wrote:
Have you look at troubleshooting section in docs? Also install video might help if you haven't seen it.
Yes. I followed the installation procedure including removing the read only flag from the files extracted from the ZIP archive.

Unfortunately there is no additional error information beyond the 500 error in the response headers. I have tried other pages in the project like contact.aspx but the same happens.

I must be missing a component but I have no idea what that might be. It is frustrating that no event log entry is created.
Aug 13, 2014 at 9:47 PM
Anyone with something more helpful than "watch a video"?
Aug 14, 2014 at 6:49 AM
Hi Apollogz,

Couple of options to do here:
  1. Zip your entire files that you have on the server.
  2. Download that zip locally
  3. Unzip that zip folder and run BE locally with Visual Studio
That should give you more exact details on your actual error.

Option #2

Install Elmah

That Nuget package sets everything up for you :)

Just install and go!

Either 2 options will show you the exact error you are having.

I bet 99.9% It is a permission error.

Make sure that your folder /Custom has read/write, and excute permissions.

Also had you tried installing BE through the Azure Gallery?

I did that and it seems to work ok.