HTTP error when accessing Admin pages (403 Forbidden error)

Oct 6, 2014 at 7:22 PM
Edited Oct 7, 2014 at 3:23 AM
I installed BlogEngine v3.0 on a Windows 2008 server, and things launched okay, however, when I am logged in and try to go into any Admin page (i.e., Settings, Users, etc.). I am getting an IIS 403 Forbidden error.

This is weird since the non-Admin pages all works perfectly.

I checked all permissions (gave full access to the apppoolidentity user for the entire site).

In IIS, I have this site set up as an Application within a larger website (i.e., http://www.site.com/blog).

Any help would be greatly appreciated. Thanks.


*** UPDATE ***

I have made some progress. If I set up the site as a standalone IIS site (i.e., not as a virtual directory/application), it works perfectly fine. Something about the virtual directory/application configuration is messing up the Admin pages.

Please help!
Nov 12, 2014 at 3:05 PM
I too have the same issue. Did you find a solution to this?
Nov 12, 2014 at 3:15 PM
I found something online about adding the following into the <appSettings> of the web.config
<add key="webpages:Version" value="3.0.0.0" />
<add key="webpages:Enabled" value="true" />
This stops the 403 forbidden message but now the cshtml in the admin pages only load as blank white pages in the browser.
Nov 19, 2014 at 5:07 AM
Hello, I was never able to figure it out. The only workaround I found was to create a separate IIS site instead of a virtual folder/application, i.e., http://blog.yoursite.com (works) instead of http://www.yoursite.com/blog (which doesn't work).

As much as I hate to say it, I ended up going to Wordpress anyway since there aren't too many third-party freelancers building BlogEngine sites and I needed one up relatively quickly.

Good luck.