Can't Log In

Topics: ASP.NET 2.0
Jun 10, 2009 at 9:58 PM

I just set up 1.5 on my local computer as a subfolder of my website - http://localhost/blog

After logging in, I am just redirected back to the default.aspx page with no visible change.  If I enter an incorrect login, I do get an error message - Your login attempt was not successful. Please try again.

I've read through the previous posts and several others have had this problem, but none of the fixes seem to be working for me.

I checked the cookies and I do have .AUXBLOGENGINE but not .BLOGENGINEROLES

I added the path /blog to the forms and roleManager elements:

<forms timeout="129600" name=".AUXBLOGENGINE" protection="All" slidingExpiration="true" loginUrl="~/login.aspx" cookieless="UseCookies" path="/blog"/>

<roleManager defaultProvider="XmlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES" cookiePath="/blog">


Anyone have any ideas of what else I can try?  I am wondering if something in my root web.config is interfering.  I added <clear/> right after the <providers> element to remove any existing items because I was getting an error referencing a provider from my root web.config, but that's didn't help.


Jun 10, 2009 at 10:02 PM

P.S.  The blog folder is set up as an application in IIS.

Jun 11, 2009 at 1:50 PM

I reset the home directory in IIS so that the blog is no longer running in a subfolder of the site, and I STILL can't log in.   I feel like I must be missing something obvious here...

Jun 11, 2009 at 5:22 PM
Edited Jun 11, 2009 at 5:24 PM

I found the problem!   In my main website I was using the UrlRewriteModule and got this error when viewing the blog:  Could not load file or assembly 'UrlRewritingNet.UrlRewriter' or one of its dependencies.

So I had put a <clear/> in after <httpModules> which fixed that error.  But apparently that somehow interfered with the cookie.

I changed it to <remove name="UrlRewriteModule"/> and now it all works fine!

Yippee!  Hope this thread helps someone else avoid wasting a bunch of time :)