This project is read-only.

Errors on a fresh install

Jul 20, 2009 at 11:35 PM

I have just installed Blogengine on my web server. I have changed the permissions etc. My web host uses the plesk control pannel to make changes to IIS. I also have access to IIS control pannel. I have done everything I can think of and it still won't launch. I have made a virtual directory called blog along with a real directory called blog and I get different errors from my workstation than I do on the server itself.

Here is the errors from my workstation hitting the web server:

Server Error in '/blog' Application.

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<customErrors mode="Off"/>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>


Here is the error hitting the sever from itself:

Server Error in '/blog' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The code subdirectory '/blog/App_Code/Reports/' does not exist.

Source Error:

Line 84:       -->
Line 85: <codeSubDirectories>
Line 86: <add directoryName="Reports" />
Line 87: <add directoryName="Survey" />
Line 88: </codeSubDirectories>

Source File: C:\Inetpub\vhosts\\httpdocs\web.config    Line: 86

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


Any ideas?

Jul 21, 2009 at 1:45 AM

Your blog application is inheriting settings from the parent application (in the root of your website).

In this case, it appears you have codeSubDirectories defined in the parent app's web.config file.

If you have access to the parent app's web.config file, I would wrap the existing <system.web> section in the <location> tag shown below to stop the parent app's settings from propagating down to sub-applications.  Note:  This change should be made in the PARENT app web.config file.

==== Parent App's Web.Config file ====
<location path="." inheritInChildApplications="false">

     <system.web>   <!-- Your EXISTING <system.web> section -->