Crash! after login

Topics: ASP.NET 2.0
May 26, 2015 at 6:17 PM
hi to all,
i have my BE.NET in my server with SQL SERVER. It Work correctly, but when login it will crash!

you can help me?

tnks
May 26, 2015 at 6:18 PM
DETAILS:

from web

Server Error in '/' Application.

Runtime Error

Description: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated.
May 26, 2015 at 6:19 PM
DETAILS

From event view of my server


Event code: 3008
Event message: A configuration error has occurred.
Event time: 26/05/2015 19.15.43
Event time (UTC): 26/05/2015 17.15.43
Event ID: 39533af396bb464fb1e6dabb3ea13664
Event sequence: 10381
Event occurrence: 2
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/5/ROOT-1-130770664362129527 
Trust level: Full 
Application Virtual Path: / 
Application Path: D:\SitiWeb\www.lucianoblancato.it\ 
Machine name: SERVERWEB 
Process information:
Process ID: 4412 
Process name: w3wp.exe 
Account name: IIS APPPOOL\www.lucianoblancato.it 
Exception information:
Exception type: ConfigurationErrorsException 
Exception message: Object reference not set to an instance of an object. (C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config line 284)
at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)
at System.Web.Configuration.ProvidersHelper.InstantiateProviders(ProviderSettingsCollection configProviders, ProviderCollection providers, Type providerType)
at System.Web.Configuration.SiteMapSection.get_ProvidersInternal()
at System.Web.SiteMap.Initialize()
at System.Web.SiteMap.get_Providers()
at Admin.Menu.BindMenu()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at ASP.default_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\47257fef\b024add6\App_Web_bjir0hf3.0.cs:line 0
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Object reference not set to an instance of an object.
at MySql.Web.SiteMap.MySqlSiteMapProvider.Initialize(String name, NameValueCollection config)
at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)



Request information:
Request URL: http://www.lucianoblancato.it/default.aspx 
Request path: /default.aspx 
User host address: 10.1.1.44 
User: Luciano Blancato 
Is authenticated: True 
Authentication Type: BlogEngine.NET Custom Identity 
Thread account name: IIS APPPOOL\www.lucianoblancato.it 
Thread information:
Thread ID: 16 
Thread account name: IIS APPPOOL\www.lucianoblancato.it 
Is impersonating: False 
Stack trace:    at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)
at System.Web.Configuration.ProvidersHelper.InstantiateProviders(ProviderSettingsCollection configProviders, ProviderCollection providers, Type providerType)
at System.Web.Configuration.SiteMapSection.get_ProvidersInternal()
at System.Web.SiteMap.Initialize()
at System.Web.SiteMap.get_Providers()
at Admin.Menu.BindMenu()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at ASP.default_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\47257fef\b024add6\App_Web_bjir0hf3.0.cs:line 0
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Custom event details:
Jun 1, 2015 at 10:52 PM
Did you configure your web.config to use SQL for membership?

don’t forget to configure membership and roleManager to use the database. They are deeper down in web.config:

<membership defaultProvider="DbMembershipProvider">

<providers>
<clear />

<add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed" />

<add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine" />

<add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine" />
</providers>

</membership>

<roleManager defaultProvider="DbRoleProvider" enabled="true" cacheRolesInCookie="false">

<providers>
<clear />

<add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider" />

<add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine" />

<add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine" />
</providers>

</roleManager>
Jun 2, 2015 at 10:50 AM
yes! thats all ok.... but admin section crash!
all website is ok... but after login crash only admin section.

it will crash after windows update of last month.... :-(

Luciano Blancato
[email removed]