Comments management - feedback needed

Topics: ASP.NET 2.0
Aug 4, 2009 at 3:33 AM

Hi guys, I just started merging Commentor into core BlogEngine code. If you have any feedback on comments management in the BlogEngine please let me know. I'll be messing around with comments related code a lot in the next few weeks, so if you have something you don't like in the way it works, now is a good time to get it fixed.

Aug 4, 2009 at 2:57 PM

Thanks for making this post and good timing as I am having some difficulties with this extension (probably an issue on my side, but not sure what).  I have reviewed all of your instructions and followed along to complete the installation of commentor into my blog with waegis. 

Using version 1.5.07 with IIS.  The blog is a sub-domain to my main website:  (removing error for time being since this is a live site)

The installation works perfectly on the local host end (IIS), but when I upload the new files to the production server I get an error message (copied below).  Strangely, when I follow the link to home page the site loads and everything appears ok...but, it is not because the remaining extensions simply quit loading - meaning only two extensions managed to properly load.  With the exception of commentor, I am only using the out-of-box extensions for the time being.

Thanks for your comments and assistance...


Ooops! I can't find the page you're looking for

You might find one of the following links useful:

You can also try to search for the page you were looking for:

You may not be able to find the page you were after because of:

  1. An out-of-date bookmark/favorite
  2. A search engine that has an out-of-date listing for us
  3. A miss-typed address
Aug 5, 2009 at 9:36 AM

If an unhandled error occurs, by default you get redirected to the error404.aspx page.

In your web.config file, change the <customErrors> tag to the following so you can see the actual error message, rather than getting the generic redirect.

<customErrors mode="Off">

Aug 5, 2009 at 11:30 AM


I've tried to change the config as stated above...still get this error message (blog is set as application, and I have set appdata folder to writeable...any other thoughts?  Btw, when I reset the web.config file then the break post extension does not work...

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<customErrors mode="Off"/>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>


Aug 5, 2009 at 3:28 PM
Edited Aug 5, 2009 at 3:29 PM


I'd like to be able to modify a comment during the approval process. For example to remove bad language or to delete the URL if it's not appropriate. Is this possible?

Aug 5, 2009 at 3:47 PM
nevets2001uk wrote:


I'd like to be able to modify a comment during the approval process. For example to remove bad language or to delete the URL if it's not appropriate. Is this possible?


Sure, it is possible in Commentor and will be possible in admin's comments section.

Aug 5, 2009 at 10:12 PM

jackmcn: If you're getting that error message, that means your customErrors tag is not set to Off.  It's case-sensitive too, so make sure it's exactly:

<customErrors mode="Off">

What do you mean the Break Post extension isn't working?  Are you seeing any errors?  Does the Break Post extension show as 'enabled' on the Extensions tab in the control panel?

Aug 6, 2009 at 5:47 AM

BenAmada: Thanks for taking the time and looking into the matter.  I made the mistake re: I have corrected the issue with respect to <customErrors mode="Off">'s what happened after uploading commentor.cs to extensions folder in AppCode, Waegis.Client to bin folder and the Commentor folder to User Controls...

  1. on page load I received authentication required box (needed to enter user name and password)
  2. did not receive any error message
  3. all extension stopped working (they loaded, were all enabled, but did not function)... [more] tag became visible in post, but post did not break.... using 'red' in comments from BBCode extensions just showed the code in preview...not the red...and on...

Could this be a 'URL' issue since I am using a sub-domain...meaning somehow they are not being resolved?  I wonder if anyone else has tried to use the extension in a sub-domain environment...


Aug 11, 2009 at 2:11 PM

In the main comment list, I'd like to see the website address entered as a hyperlink on the name, much like it is displayed as comment on the post page. I often judge comments based on the Url, and the presence of one generally increases the risk of it being spam too.

In the configuration area, I'd like to be able to define filter rules on the website field.


Aug 19, 2009 at 6:22 PM

Here are basic rules that BlogEngine will let you turn on/off to help moderate comments:

for each user (user name (+ email?), not IP) :
- if user authenticated - all comments approved
- if at least x comments approved - add to white list, all comments approved
- if at least x comments rejected (marked as spam) - add to black list, all rejected
- (possibly) verify if email address exists

- add option to block IP on comment delete (helps when spammer changes names), this will automatically create new filter.

If you have more suggestions, speak out!