Post.PermaLink wrong in

Dec 27, 2015 at 3:27 PM
Edited Dec 27, 2015 at 3:28 PM
After upgrading from to no Disqus comments are shown for posts.
"Post.PermaLink" is rendered as friendly name in post.aspx but all comments are registered for the real permalink (a GUID).
How can I fix this?
There is also no Permalink button anymore when opening a post.
Dec 27, 2015 at 4:33 PM
In admin/settings/comments there is an option to use Disqus.
The markup mostly driven by theme - you can check PostView.ascx for your theme and modify it if needed.
Dec 27, 2015 at 4:52 PM
Disqus is enabled, this is not the problem.
It is also independent from the activated theme.
For example take this post:
The "disqus_url" rendered in HTML is the same URL, but is should be "" which I also see on the Disqus admin page. In post.aspx (in the root directory) the code is
var disqus_url = '<%= PermaLink %>';
So Post.PermaLink is not returning the post permalink, it is returning the normal url.
Dec 27, 2015 at 4:57 PM
Edited Dec 27, 2015 at 5:05 PM
Does it work with standard theme? If yes, check what is the difference.

And you can change url in post.aspx to:
var disqus_url = '<%= string.Format("{0}post.aspx?id={1}", Utils.AbsoluteWebRoot, Post.Id) %>';
Dec 27, 2015 at 5:23 PM
Also, can you try to use this core DLL - it is recompiled with permalink using GUID:!630909&authkey=!ADOc3VNm-EwSOPk&ithint=file%2cdll
Dec 27, 2015 at 5:34 PM
It's not working with standard theme.
I did the change in post.aspx and now it is working.