Trying to upgrade from 3.1.1 to 3.3 - it says I already have the latest version?

Topics: Controls
May 11 at 12:39 PM
Hi there,

As the title states, I'm trying to upgrade from 3.1.1 to 3.3, but each time I do, I am greeted with the message "Looks like you already running latest version!".

Considering I haven't upgraded the blog since before 3.2 was released, and it specifically states it is running version 3.1.1.0 at the bottom of the blog, I'm at something of a loss as to why it thinks I'm running the new version. What might be causing this confusion?

Thanks for any help!
Coordinator
May 11 at 5:26 PM
When you go to dashboard, it compares your local version with latest available on BE site.
If you look at network activity with any dev tools (F12 in IE or Chrome, Firefox etc) you should see call similar to this:

http://yoursite.com/api/setup?version=3.1.0.1

The latest on BE is 3.3.0.0, so verify your local is really 3.1.0.1
For example, I can check version with SIOC call like this:

http://zoo.azurewebsites.net/sioc.axd

And look for agent version, currently 3.2.2.1:
<admin:generatorAgent>BlogEngine.NET3.2.2.1</admin:generatorAgent>
May 11 at 5:47 PM
Hi Rtur,

Yeah, network activity monitor on Chrome is also confirming that it's 3.1.1.0.

Where does it compare the available update version with the current version?

Thanks,
Coordinator
May 11 at 10:52 PM
Look at checkNewVersion function in this file: https://blogengine.codeplex.com/SourceControl/latest#BlogEngine/BlogEngine.NET/admin/controllers/dashboard.js

If API call (see previous comment) returns newer version number, script displays upgrade message.
Jun 23 at 12:45 PM
Hi Rtur,

Sorry, only just come back to this issue after having to focus on other things. Is this API call for displaying the notice on the dashboard that mentions there is a new upgrade? If so, I am seeing that perfectly fine.

It's on the actual /settings/upgrade/ page that it is saying I have the latest version. Is there a variable I can change manually in the code to allow the update to occur?

Thanks,
Oct 25 at 7:55 PM
I also have this exact same issue and would like to get auto-upgrade working, because I am having a heck of a time trying to manually upgrade ...

Thanks!