Search Box Text

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Jul 29, 2016 at 10:23 PM
Edited Aug 4, 2016 at 9:45 PM
I'm working on the XML version of BE 3.2.0.3 and tried to remove the default "Enter search term or APML uml" text from search box, by looking in all the settings XML files. I could not find a setting for this text.

Can someone point me in the right direction? Do I have to download the code version and get fresh DLLs?
Jul 30, 2016 at 12:53 PM
Edited Aug 3, 2016 at 8:47 AM
You can edit the default text by looking at:

C:\InetPub\wwwroot\Blog\App_GlobalResources\labels.XX.resx ( XX stands for localization language)
<data name="filterByApml" xml:space="preserve">

or

C:\InetPub\wwwroot\Blog\App_GlobalResources\labels.resx
<data name="filterByApml" xml:space="preserve">

or

C:\InetPub\wwwroot\blog\App_Data\settings.xml
<searchdefaulttext>Enter search term or APML uml</searchdefaulttext>

;-)
Jul 31, 2016 at 3:54 AM
I can't get that to work. The third option - the settings file is obviously not being used for this as it has different text...
Aug 3, 2016 at 5:14 AM
Edited Aug 3, 2016 at 5:22 AM
Hi anthony
You can find the search text in file below
\App_Data\settings.xml
Replace the below key in xml
<searchdefaulttext>Enter search term or APML url</searchdefaulttext>

This worked fine for me for BE v3.3

If change does not work then restart your application it will work then
Aug 4, 2016 at 9:31 PM
Edited Aug 4, 2016 at 9:31 PM
This is what was in that settings file:

<searchdefaulttext>Enter search term</searchdefaulttext>

I restarted the site in IIS but it's still showing: "Enter search term or APML url".
Aug 10, 2016 at 6:40 AM
Edited Aug 10, 2016 at 6:40 AM
You can do the following steps
  1. Login to the blog with admin credentials
  2. You will see the admin menu as in http://prnt.sc/c3u3eu
  3. When you click the edit button in step 2
  4. This menu http://prnt.sc/c3u3pi will open.
  5. Change the text as in above image
Hope that helps
Aug 10, 2016 at 1:22 PM
Edited Aug 10, 2016 at 1:24 PM
Hi,

Thanks for your help, that worked! :)