Blogpost is only visible after a few hours

Topics: Controls
Feb 17 at 10:13 AM
Hi there

When I write a blogpost and publish it right after saving it, I logout and search for the post. I have to wait at least 1 hour until the post is finally visible for the public.

Do I have to change something?
Thanks for helping me out.
Feb 17 at 11:08 PM
Did you try checking the blog while in incognito/private browsing mode to make sure that it's not a caching problem?
Feb 22 at 8:07 AM
Sometimes it didn't happen, but for some of my writers it happens all the time. When I use incognito it works. But is there a way to clear the cache (serverside?) by code?
Feb 22 at 4:30 PM
I think you should raise this as an issue on the GitHub page - you'll probably be able to get some more specialized help there. I don't know whether this is a client-side or server-side caching problem.

https://github.com/rxtur/BlogEngine.NET/issues
Feb 22 at 11:05 PM
Check that the 'Timezone' is correct. You find it under Settings - Basic
Mar 29 at 3:55 PM
Did you ever find a solution to this? We experiencing a similar issue.
Mar 30 at 7:25 AM
Edited Mar 30 at 9:12 AM
Hi,

It is the Server Off Time settings in BE.

You have to set the Time according to your Time zone of your Actual web server.

So if your Website is hosted in the Pacific Time Zone, but you are in the Eastern Time Zone, you will need to add 3 minus or plus not sure :) Hours to your Server Off time setting in BE.

Trial in Error in testing which setting works for you will eventually figure out what time difference you will need for it to work.


In latest version of BE you just set the time zone of your server and that is it.