need help embedding blogengine into existing site

Topics: ASP.NET 2.0, Themes
Aug 22, 2009 at 3:41 PM
I got blogengine working on a testsite as a standalone application just fine.  Now I wanted to try to embed it into a table on an existing page that uses a template.  And I am having trouble.  I should preface this to say I am not an experienced programmer.

I loaded the .web into a folder called testblog.  I added the following 2 lines to the beginning of my blog.aspx page (very first 2 lines)

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="testblog/default.aspx.cs" Inherits="_default" %>
<%@ Register Src="testblog/User controls/PostList.ascx" TagName="PostList" TagPrefix="uc1" %>

before the <html> tag.  Then, between the appropriate <td> </td> tags I pasted

<asp:Content ID="Content1" ContentPlaceHolderID="cphBody" Runat="Server">
  <div id="divError" runat="Server" />
  <uc1:PostList ID="PostList1" runat="server" />
  <blog:PostCalendar runat="server" ID="calendar" 
    Width="100%" />    


When I run my testsite/blog.aspx I get the followig error

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0246: The type or namespace name 'BlogEngine' could not be found (are you missing a using directive or an assembly reference?)

Source Error:

Line 4:  using System.Collections.Generic;
Line 5:  using System.Text.RegularExpressions;
Line 6:  using BlogEngine.Core;
Line 7:  using BlogEngine.Core.Web.Controls;
Line 8:  

Source File: d:\home\\subdomains\test\testblog\User controls\PostList.ascx.cs    Line: 6

What do I do with this?  Ay help is greatly appreciated!

Best regards,


Aug 23, 2009 at 1:30 AM

Make sure the BlogEngine.Core.dll file is in the BIN directory.

Aug 23, 2009 at 2:31 PM
BenAmada wrote:

Make sure the BlogEngine.Core.dll file is in the BIN directory.

 It is there, thanks, but this is not the problem :-(

Apr 19, 2010 at 9:02 AM


I am getting the same error message.

please somebody help. and yes, "BlogEngine.Core.dll" file is there in Bin directory.

But still i am getting this error message.

Apr 19, 2010 at 10:49 AM

Is this a standalone BE application?  Or did you put it into an existing website?

If you have BE installed in a subdirectory off of the root website, you'll want to make the subdirectory an 'application' in IIS.