This project is read-only.

Weird problem with Windows Live Writer and BE

Nov 15, 2009 at 4:21 PM

I have begun using the latest version of Windows Live Writer with BlogEngine.NET, and I am having a strange problem. Everything works perfectly, except that when the entry is published, the dash and apostrophe characters are changed to a question mark. I use WLW to also publish to a Wordpress blog on the same server with no issues, so it seems to be something specific to BE - any ideas on how to solve it?



Jan 18, 2010 at 8:58 PM

I also am having the same issue. I am using SQL Server as the back end.

Jan 20, 2010 at 4:55 AM

I had a similar issue with single & double quotes on MySQL 4. In Windows Live Writer, I went to Tools/Options, clicked Editing, and unchecked the Replace "straight quotes" with "smart quotes" option and unchecked Replace other special characters. Sounds like you need to uncheck Replace hyphens with dash.

- B

Jan 21, 2010 at 4:59 PM

We can definitely try that, but we have already tried unchecking replace straight quotes with smart quotes and still have the issue. Now, with that said, we did so after the post was written and posted for the first time. After noticing the problem, we deleted the post and re-posted it with the option turned off. It could be possible that LiveWriter retained the smart-quotes. We will see.

Any other tips would be greatly appreciated.

Feb 19, 2010 at 4:13 AM

Any thoughts or helpful hints on this one?

Feb 19, 2010 at 6:19 AM

Are you using MySql?  I think what you'll want to do is change the character set for the tables (be_Posts, for example) from latin1 to UTF-8.  Those quotation marks or other special characters are probably not in the 'latin' character set.  The MySql setup script for BE appears to be using the latin1 character set.  You can Google around for for "smart quotes mysql".  Here's one result.

Feb 23, 2010 at 4:44 AM


I am using SQL Server 2005. What I found is that LiveWriter replaces the quotes with their smart quotes as you type them, so you must turn off the replace "straight quotes" with "smart quote" prior to creating the post. We had tried turning off the option prior to posting, but after creating the post. It appears to all be working now that I have that option, as well as the dashes and special characters option, turned off.