Possible bug with language and comment emails?

Feb 18, 2010 at 4:57 PM

The lang-code of my blog is set to en-us.  Today I receive a comment notification email from a user who specified German as their country. The Approve/Delete links in the email are in german (i think...i can't read it)  Is this my design, and if so why? Shouldn't it come across as English because that is what I have the blog set as?  (version  Here is the email:



Catering in Siegen

I don’t usually reply to posts but I will in this case. WoW ::::IDENTIFIED AS SPAM::::

BeitragSupporting OpenId in an asp.net MVC site

Löschen | Genehmigen

Author information

Name: Catering in Siegen
E-mail: Culpepper26@t-online.de
Website: http://partyservicesiegen.de/kaeseplatte/
Country code: DE
IP address:
User-agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
Feb 18, 2010 at 5:42 PM

The latest version of BE (1.6) has addressed this.  The Approve/Delete links are now in English, or whatever the default language of the machine the blog is on is.

Btw, I don't remember exactly, but I think if you have explicitly set the Language on the Settings tab to English, then the Approve/Delete links should always appear in English.  But if you have the Language set to "Auto", then it can change to other languages, depending on the language of the website visitor (like you've shown in your post).